Jump to content
Corsair Community

Corsair Scimitar Pro RGB Sensor problem?


Neozyy
 Share

Recommended Posts

So I've bought a Corsair Scimitar Pro RGB Mouse from a local store a few months ago and couple days later I noticed something was off

 

When I lift up the mouse and put it back on my mousepad the cursor jumps to the sides.

I found that lowering the lift height from high to low should fix this problem.

 

Setting it on low made it much less noticeable and happen much less often, but apparently these jumps still happen even on low settings.

I wonder whether or not that's an actual problem or its just the way this mouse works.

 

[ame]

[/ame]

 

Is that how this mouse is supposed to behave on high lift height settings?

I know the low settings fix almost everything, but if this mouse is faulty, I will replace it.

 

Is there anyone with this mouse that can tell me if their mouse is behaving that way?

 

*I'm using 550 dpi, higher dpi results in longer jumps.

*Polling rate doesnt change anything.

*I have the latest firmware and icue versions.

*Doesn't matter if Icue is on or off.

*I did the same test with a Logitech G502 Hero as well as my old Redragon Perdition M901, neither of those had this problem

*Surface doesn't seem to change anything, tested it on my desk aswell.

Edited by Neozyy
Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees

Hi Neozyy,

 

This is characteristic to how any optical mouse works, and I can confirm this same behavior happens with a Logitech G502 as well after testing. You should check out one of our new extra-long mousepads, so you won't have to lift the mouse at all!

Link to comment
Share on other sites

Hi Neozyy,

 

This is characteristic to how any optical mouse works, and I can confirm this same behavior happens with a Logitech G502 as well after testing. You should check out one of our new extra-long mousepads, so you won't have to lift the mouse at all!

 

I have the Logitech G502 Hero SE and this problem doesnt exist at all as mentioned in the post.

I also have a 91cm long mousepad so thats not a mousepad length problem i lift my mouse a lot because i play on low dpi and i dont know how such thing can be justified since a mouse like this should be suitable for any DPI just like the G502.

 

I also had a Redragon Perdition M901, much cheaper than Scimitar and I've never had such jumps, i paid for a corsair mouse to get quality and what i got is this lift function that doesnt function but causes weird stuff like that.

 

if thats how it works, then why aren't there other posts about this unusual behavior? anyone with a scimitar mouse that can confirm they have the same experience on high lift height settings?

Edited by Neozyy
Link to comment
Share on other sites

 Share

×
×
  • Create New...