Jump to content
Corsair Community

Updated the other day, and now no MIC


RabicanShiver
 Share

Recommended Posts

So, a few days ago I updated icue and right after I did, the red light on my Void Pro RGB (wire version) lit up. THe red light on the mic signals that the mic is off. No matter what I did, I could not get it back on. I assumed that it was physically broken. So I did what anyone would do... ordered a new headset. I get it, install it, and red mic light... go into discord, no mic. I uninstall icue... mic works fine. However, playing Hunt Showdown, the game sounded funny... so I thought hmmm... it sounds better with icue running.. I guess the equalizer stuff.... Anyways, reinstall icue... mic turns off, red light back on.

 

When I press the side "mic" button, which for the last two years has always muted my mic, it now turns on or off "mic feedback" and not the actual mic itself. But no matter what I do, I cant figure out how to turn the mic on. I tried trouble shooting in windows, sound settings, etc. I have the mic selected as the void pro and not another device... and I know its not hardware related because it worked five minutes ago without icue running. I also have a mic when I use my crappy webcam that has a mic paired with it.

 

So... can anyone tell me whats going on?

 

Icue version 3.33.246 if that makes any difference.

Link to comment
Share on other sites

My mic is stuck on mute after the new iCue update. I have tried everything from reinstalling iCue to manually deleting and reinstalling the audio drivers. Mic works fine when iCue is not installed. Worked fine before the update. I have reached out to Corsair's support team but no response yet. If this problem isn't fixed in a few days I'll have no choice but to go with a different brand which is disappointing as I've been a life long corsair customer. This is apparently a common problem for Corsair from what I've read online. It is certainly one of the more frustrating I've come across.

 

 

If any information surfaces I will post back here.

Edited by zshepard
Link to comment
Share on other sites

hmmm thats unfortunate... I was really hoping I was just doing something wrong.

 

Yeah I will give this about two more days, and then the headset is going back, and I will likely not look back to this brand... I usually stay loyal to whatever I am using... and I do not enjoy problems with my hardware.

Link to comment
Share on other sites

 Share

×
×
  • Create New...