Jump to content
Corsair Community

Corsair One i160 not recognizing USB 3.1 Gen1 Ports Windows 10


vishnutej9492
 Share

Recommended Posts

I've been using my corsair i160 for about a year and update windows whenever but all of a sudden, from about 2-3 weeks ago all my USB ports barring 1 stopped working. After some research I realized that all of my USB 3.1 Gen1 ports would power the device, but not be recognized in windows and in BIOS as well. I've tried restarting my computer multiple times and restored my system to an earlier point and then boom, everything was back to normal. I created a new system restore point and everything worked for about 10 days after.

 

Again recently, the same issue happened again and I tried doing the restore multiple times but it didn't work this time.

 

Tried doing a CMOS reset, a BIOS factory default settings restore and none of them worked.

 

The issue I'm referencing is a This device cannot start. (Code 10) error that appears on the Generic USB xHCI Host Controller. After doing some googling there was no clear solution and looked like it could be a driver issue but I tried multiple things like uninstalling and attempting to reinstall an older version of the driver (to no avail). I also tried doing the Windows RESET as part of the corsair PC and that didn't work either. I tried a clean install of Windows 10 Creators (2004) and that didn't work either. I tried installing a previous version of Windows 10 assuming the update might've messed with my drivers and that didn't work either.

 

In the BIOS menu as well, when I look at the hardware explorer and have devices plugged in to the USB 3.1 Gen1 drivers, it would not show up there which I thought was super weird.

 

I'm all out of ideas and really not sure why this is suddenly happening and would appreciate any information or guidance in attempts to fixing this.

 

The driver in question is usbxhci.sys. Another thing I noticed during all of this shenanigans was that my computer was not shutting down or restarting properly by itself anymore. It would always power down, but passively be on with the lights on and not really do anything and run in the background. I would then hold down the power button to make sure it powered down completely.

 

Spent a lot of time on this and I feel helpless and out of ideas and don't feel like I'm close to a solution therefore any help would be greatly appreciated.

Link to comment
Share on other sites

Did you run Live Update? Does it show any drivers available? Did you redownload and install the drivers from the Corsair website?

 

I'm no expert, but the fact that your USB controller shows up as "Generic USB xHCI Host Controller" suggests that the driver isn't installed. I have an i160 and none of my USB controllers are listed as generic.

 

What did you download through Windows Update? I noticed for the first time recently that Windows Update offers a bunch of driver updates as "Optional updates." The dates of the drivers it offers, though, are all older than the Corsair One drivers available through Live Update or the Corsair website. So I didn't bite. Maybe in your case Windows Update installed a bunch of old drivers?

Link to comment
Share on other sites

 Share

×
×
  • Create New...