Jump to content
Corsair Community

Corsair H100i Platinum fans no longer responding


Mav281
 Share

Recommended Posts

Hi all,

 

I've had my Corsair H100i attached to my Ryzen 9 3900x for five or six months now and have had absolutely no issues at all, that was until yesterday:[pouts:

 

Whilst working on my laptop, I happened to glance at my second screen which always shows HWInfo and noticed that the PC was running hot, despite the fact it was just idling away in the background. Quick scout around and I quickly realised that the fans on the H100i are only spinning at 360RPM. So I jump into iCUE assuming I’ve inadvertently adjusted them at some point but no everything is as it should be – the fans just appear to have stopped responding entirely. I messed around with the settings for the fans and the pump and the pump responds normally changing its speed as I switch between various profiles, but the fans no longer respond at all.

 

I’ve opened up the case and had a nose around in there to make sure nothing has been dislodged. All connectors are firmly in place, and I’ve disconnected and reconnected all the appropriate cables but nothing seems to make any difference.

 

Anyone got any magic suggestions or does this sound like a faulty unit?

 

Thanks the assistance.

Link to comment
Share on other sites

You might try force loading the firmware. There seem to be a few of these stuck fan issues about for the Platinum/XT coolers. This resolves it for some, but there are other possible problems that won't be corrected by this.

 

CUE Settings -> H100i Plat. -> check for firmware update (it says up to date), then force update. The cooler will go offline for 3-5 seconds as it reloads.

Link to comment
Share on other sites

You might try force loading the firmware. There seem to be a few of these stuck fan issues about for the Platinum/XT coolers. This resolves it for some, but there are other possible problems that won't be corrected by this.

 

CUE Settings -> H100i Plat. -> check for firmware update (it says up to date), then force update. The cooler will go offline for 3-5 seconds as it reloads.

 

Thanks, good suggestion.

 

I've have already been through and checked that firmware is update to date, apps are all up to date and there is nothing outstanding.

 

Anyone got anything else?

Link to comment
Share on other sites

 Share

×
×
  • Create New...