Jump to content
Corsair Community

Horrible Audio - Void Elite Surround


Ziggyw82
 Share

Recommended Posts

I just bought the Void Elite Surround. The Mic is Great! those on discord hear me so clearly. However, EVERYTHING SOUNDS HORRIBLE! no matter how I change the EQ, settings, etc. Everything has a digitally, metallic sound. Aditionally, the spacing of the sound is bad causing everything to sound flat... like listening to AM radio vs FM radio. I know it's as a result of the ICUE software.

 

If I use the headset via the 3.5mm jack, audio sounds AMAZING! but through the USB adapter so I can use the Mic at the same time on my PC, and everything sounds HORRIBLE! The problem is I can't use the mic when using the 3.5mm jack on my PC!... so... only good when listening to music (which is an absolute necessity to actually enjoy music).

 

Corsair desperately needs to work with a sound engineer to redo the tuning and audio quality of the drivers/settings for this headset. Sadly, I'm going to have to try and return the headset or sell them to go with another brands product if Corsair has no intention to fix the issue... but from what I gather on other forum posts, both on these forums and elsewhere on the internet, they have no intention of doing. THat is sad/pathetic... I was hoping to only have to run ICUE as all my other periphrials and my liquid cooler for my CPU are all corsair.

Link to comment
Share on other sites

  • Corsair Employees

It's possible the headset could be set to the wrong audio format in Windows, and is easily fixed.

 

Right click on the speaker on the Windows system

Select "Sound Settings"

Select "Device Properties" under your output device

Select "Additional Device Properties" (on the bottom or right depending on size of your window)

On the Advanced tab you should have a drop down with different options to select

 

8 Channel, 16bit, 48,0000 Hz should be the best option but you can try the others as well.

Link to comment
Share on other sites

That is exactly how it is set. The issue is with how the software/firmware for ICUE is set.

 

Again, when using the 3.5mm jack the headset sounds amazing. However, using the USB adapter the sound just sounds like I went from HiFi to LoFi, or FM to AM. Just a flat, metallic, hollow sound.

 

Please, PLEASE have your software team work with a sound engineer (like the people that works for a recording studio) to work with your team to do the next update to the software & firmware!

 

But, I'm sure y'all have no intention of doing that, so I'll end up going with another brand's product.

Link to comment
Share on other sites

I don't know what Corsair is doing but the Void Pro is their only headset where I could keep 7.1 on all the time without any issues. I've tried the Void Elite and Virtuoso and stereo sounds fine but once you change to surround everything sounds super low bitrate and slightly distorted.
Link to comment
Share on other sites

 Share

×
×
  • Create New...