Jump to content
Corsair Community

Disappointed QL120 RGB fans


Pteradon
 Share

Recommended Posts

Hello Everyone,

 

a few days ago i deceided to put some eyecandy in my case.

I bought 9 QL120 RGB white fans and the commander Pro unit.

 

Sadly it doesn't work like it should.

All the fans are spinning but no RGB.

 

The 2 Lighting Node Cores are not showing up in the iCUE program.

The Commander Pro is showing up and my 1080Ti and the mobo.

I can set up the speed of every fan.

 

I have searched on the web for a solution and was suprised about how many topics there were about this problem. (and no solution found)

So i am quit a bit disappointed in Corsair QL120 RGB fans, wich cost me about 400 euro. (approx 473 Us dollar)

 

I have turned off the Fast boot function in the bios.

Fresh install with up to date drivers.

Fast Startup is in W10 disabled.

Tried to reset the Node Cores, which worked untill i turn of my computer.

Tried to connect the usb-connector on a different connector on my mobo, with no result.

Tried USBDeView and there are 2 unknown devices connected, wich i presume that those are the Lighting Node Cores. (see attachment)

 

If it is truely those Node Cores wich are connected but unknown, is it wrong to think its a faulty software of Corsair?

1294415341_Lightingnode.thumb.jpg.a1a5ea07600ec45bd44174b0296054f2.jpg

Link to comment
Share on other sites

Well, it's possible, I guess, that the highlighted items are the LNC but the Vendor ID is completely wrong; Corsair's vendor id (VID) is 1b1c.

Which version of iCUE are you running?

Also, have you made sure to update the drivers for your onboard USB controllers/motherboard/chipset?

 

Oh ... and if you have the CoPro, you can use 2 RGB Fan LED Hubs (which would be separate) and just control the RGB for the QLs from the CoPro. I know it's an additional cost but, personally, that's how I control mine. Not a fan, personally, of the LNC.

Link to comment
Share on other sites

Thank you for your reply.

 

I am running the iCUE version 3.33.246

 

At first i had updated my mobo with the latest bios version.

After that i formatted my ssd and installed a clean/fresh W10 x64 and did every windows update.

After the install of Windows i downloaded all the latest drivers for my mobo from the Asus site.

 

I have just tried something with one of the Lighting Node Cores.

I disconnected the LNC powerline off from the Commander Pro Unit and connected direct on the second usb2 connector on my mobo. Now this LNC works now without any problems.

 

I also saw that there is a light-indicator on the Commander Pro unit, which isn't burning. Do i have a faulty Commander Unit? (See attachment)

CORSAIR_CL-9011110-WW-01.thumb.jpg.11d9a1a36588cecf5d5516601affae0e.jpg

Link to comment
Share on other sites

I have now all fans running with RGB.

 

I read a solution of putting a NZXT Internal USB Hub in front of the Corsair line.

 

The NZXT Hub is connected to the mobo.

The Commander Pro and 2 LNC are connected on the NZXT Hub.

 

iCUE program sees now both LNC, the Commander Pro, the VGA and mobo.

Link to comment
Share on other sites

  • 1 month later...
 Share

×
×
  • Create New...