Jump to content
Corsair Community

Corsair Scimitar FFXIV Lag issue


ranole
 Share

Recommended Posts

Hi

 

I just bought the Scimitar to use with FFXIV. I set up iCue for my macbook pro and when I sign in and try to use it there is some major lag. I first thought it was my internet but I used my old mouse and everything is fine. Any suggestions? I really want to use this new mouse.

 

I am running FFXIV on a Macbook pro with Mojave. 16GB Ram

Link to comment
Share on other sites

  • Corsair Employees

Hi ranole,

 

Have you tried performing a soft reset on the mouse? To reset a Scimitar Pro RGB:

 

  1. Unplug the mouse.
  2. With the mouse unplugged, hold down the left and right mouse buttons.
  3. While holding down the mouse buttons, plug the mouse back into the computer.
  4. Wait for the mouse’s LEDs to begin flashing, then release the buttons.
  5. Unplug the mouse.
  6. Plug the mouse back into the computer.

 

If resetting does not resolve your issue, then please contact our support team by opening a ticket at https://help.corsair.com as they'll be able to help you troubleshoot and provide any necessary solutions.

Link to comment
Share on other sites

  • 3 months later...
I'm having exactly the same problem, in the same game. I bought this mouse to play Final Fantasy XIV and the delay of the mouse buttons compared to the keyboard is immense. In some situations it's like If the buttons just died. This is my first mmo mouse and I really liked it , but FFXIV is really the only thing I play and I bought it exclusively for that so I would really like to be able to solve it soon :(: . Thank you for any information you may give me :o:
Link to comment
Share on other sites

 Share

×
×
  • Create New...