Jump to content
Corsair Community

Dark Core RGB Wireless Mouse Lag


Recommended Posts

So the only way I can play R6 Siege now is in wired mode, any time now I play wireless, ill get what seems to be lag when moving the mouse. It almost seems like the sensor stops tracking and it happens alot. It never did this when i first got it 3 months ago. I have updated, re-paired device, you name it. Anyone else with this issue? I've never had this issue with any other wireless mouse I have used. Games are unplayable via wireless, for me anyway.
Link to comment
Share on other sites

  • Corsair Employees

Hi creed0330,

 

Have you tried performing a soft reset on the mouse? To reset a Dark Core RGB/SE:

 

  1. Set the power switch on the bottom of the mouse to OFF.
  2. Hold down the Forward and Back side buttons.
  3. Hold holding down the side buttons, set the power switch to ON.

 

If resetting does not resolve your issue, then please contact our support team by opening a ticket at https://help.corsair.com as they'll be able to help you identify any issues and provide a solution.

Link to comment
Share on other sites

My apologies, i have the dark core pro, not sure if that matters. I have tried what you have recommended both unplugged and plugged in, it does nothing at all. The mouse is rendered useless when unplugged and toggled in the middle position which is usually used for wired us.
Link to comment
Share on other sites

I've seen some other instances with other corsair mouse users, not specifically the same model as mine, where similar things are happening. In their case, it seems to be the ICUE lagging their system, only when they move the mouse. I will check this evening to see if i am getting FPS drops when mouse is in wireless mode, but as mentioned, it almost feels as the sensor stops tracking momentarily. I have died many time when transitioning from one aim point to the next b/c the mouse just stops tracking. I will provide feed back later.
Link to comment
Share on other sites

I have the same issue and the same mouse (Dark RGB Pro SE). When on the 2.4GHz wifi connection it lags, but when bluetoothed no issue. Wondering also if it is the iCUE that is causing the problems. When under bluetooth the mouse is not able to talk with iCUE where is with the 2.4GHz wifi stick it does. Wired I have no issues either.
Link to comment
Share on other sites

  • Corsair Employees

Does the issue occur when iCUE is closed and exited out of? Is it only while games are running or even on the desktop? Below is another helpful guide on dongle placement which can improve connectivity. We recommend have the dongle in line of site of the mouse for the best connection.

 

https://forum.corsair.com/v3/showthread.php?t=174791

  • Like 1
Link to comment
Share on other sites

  • 2 months later...
So all my peripherals have been corsair apart from my mouse as nothing I've tried could compare to my G502. Finally impulse purchased the Dark Core RBG PRO SE. I was super excited to finally have all my stuff match and a single program for managing all peripherals. Only thing is now I'm finding input lag to be a massive issue. I have double checked to confirm that the dongle is connected to a usb 3.0 port because i thought that may be it, nope, So i used the extension and put the dongle no more then 18inches from the mouse, in line of sight. Nope still lagging. So i think to myself well okay wireless was never a deal breaker for me anyway ill just use it wired. NOPE. STILL lagging so I'm flat outta ideas and torn because on one hand matching, satisfying, etc and being stuck with lag or going back to my 502 as nothing else as far as corsair mice peak my interest apart from the Ironclaw but Im concerned it may be Icue so even a new mouse wont fix it.
Link to comment
Share on other sites

  • Corsair Employees
So all my peripherals have been corsair apart from my mouse as nothing I've tried could compare to my G502. Finally impulse purchased the Dark Core RBG PRO SE. I was super excited to finally have all my stuff match and a single program for managing all peripherals. Only thing is now I'm finding input lag to be a massive issue. I have double checked to confirm that the dongle is connected to a usb 3.0 port because i thought that may be it, nope, So i used the extension and put the dongle no more then 18inches from the mouse, in line of sight. Nope still lagging. So i think to myself well okay wireless was never a deal breaker for me anyway ill just use it wired. NOPE. STILL lagging so I'm flat outta ideas and torn because on one hand matching, satisfying, etc and being stuck with lag or going back to my 502 as nothing else as far as corsair mice peak my interest apart from the Ironclaw but Im concerned it may be Icue so even a new mouse wont fix it.

 

Hi t68knight,

 

If you use the mouse without iCUE running in the background, is there any difference?

Link to comment
Share on other sites

  • 2 weeks later...
So I have noticed this stutter or lag where the mouse kind of doesnt register as if its been lifted off the mat, only happens when I play R6 Siege. It does it whether ICUE is running or not. I dont recall this happeneing when i first got the mouse. Now I run the mouse in wired mode and no issues, kind of defeats the purpose tho... any thoughts?
Link to comment
Share on other sites

Well, i guess we just have to deal with it as there seems to not be much support on this issue. ICUE is by far the worst software created. It seems to conflict with almost everything... Point of getting this mouse was wireless use, now it stays plugged in all the time. Like I said it feels like the mouse is lifted off the pad and stops tracking....
Link to comment
Share on other sites

  • 1 month later...

I too noticed this issue after a few months of working great. My receiver is about 6 inches from the mouse with direct line of sight. I use my laptop with the mouse on the right hand side with the usb receiver on the right usb port and I get what I can only describe as lag. It will do it when gaming and when working, almost as if it lost connectivity. I also get the same issue on Bluetooth. Ive done the soft reset option and it didnt make a difference, made sure both icue and the mouse firmware are on the latest version.

 

Edit: Initially I thought it might have been the mouse pad (maybe dirty or the design was causing the sensor to have issues) so I tried out a different one that was all black and the issue still persist.

Edited by Indecision1991
Link to comment
Share on other sites

I have been having this problem since about seven months after getting my Dark Core RGB mouse. I have reset everything more than once. I have reinstalled everything more than once. Once I turn on/wake up my mouse it works just fine, but after about five minutes it starts to lag BAD. It's barely usable as a normal mouse, forget playing any games with it. It will basically register every other mouse click, and there's no telling where it might end up on the screen when you move it.

 

Edit: It's the same with iCue running or not. I just now had to click "submit" and "edit" more than once because of this problem.

Also, the dongles are in the front of my PC case, line of sight, about six feet away.

Edited by pushmonk
New thoughts
Link to comment
Share on other sites

  • 3 months later...
I too am having lag issues when using 2.4 GHz. Not as much when not in any game, but obviously that doesn't help. This only started happening when I got my new PC. On the laptop I played on before I had no such issues. I've tried restarting the mouse and moving the receiver, but neither made any difference.
Link to comment
Share on other sites

So many moons ago when i had one of the first Logitech Wireless gaming mice, I experienced a similar issue. I later found out that it was my desk causing the issue. Tempered glass and wood do not cause any problems, but when i had an alloy based desk top if my mouse got to close to the desk (while using the keyboard tray for mouse and keyboard) i would dead zone and the dongle would lose contact with the mouse. So i relocated my computer to under the desk, and then if my keyboard tray was not open all the way and my mouse went between the metal tray and desk the mouse would go wild as if it was getting ghosted signals. Have not tested to see if these are still issues that can happen but could be something to look at. I just avoid metal stuff being between the dongle and the mouse these days.
Link to comment
Share on other sites

  • 2 weeks later...

I recently had to return the Dark Core RGB Pro (Non-SE) because of these issues, but it was more than just lag. It cut out completely, wouldn't even register being connected to iCUE. The only thing that worked was bluetooth mode, as when it was connected via USB-C, the left and right click would intermittently not work at all. I reinstalled iCUE, completely removed all of the drivers and even the Corsair folder from the registry, restarted, and the issue persisted. This was after the mouse working just fine for 4 solid days as well. I tried moving the receiver to a USB 2.0 port, and the issue persisted, so I moved it back to the USB 3.0 port. I tried moving the mouse so that it was literally within 3 inches of the receiver, and the problem persisted. At one point, unplugging and plugging the receiver back in caused my PC to have a bluescreen error as well. I returned the mouse for a new one and it isn't doing anything yet, but one thing that I'm doing differently is that I am not updating the firmware on the receiver or the mouse, as my issues started popping up after that. I did force firmware updates to see if that solved the issue on the mouse that I returned, but the issue persisted.

 

As a side note, I will also add that whenever I try to upgrade the firmware of my Corsair Vengeance PRO RAM, iCUE crashes in the middle of the update. I'm starting to believe this is an iCUE problem, rather than a hardware problem.

 

Edit: I also did the reset on the mouse both by holding the the two side buttons while powering on, and also while holding left and right click, and the issue still persisted.

Edited by Broghan
Adding Information
  • Like 1
Link to comment
Share on other sites

Bought this mouse (Dark Core Pro SE RGB) a couple months ago and it seems like things went weird one to three weeks before if I'm correct, i guess around the same time that the latest firmware update came out. Maybe a day later I had connection issues, but wired instead of wireless (or bluetooth). From then and currently, my mouse randomly shuts off for a couple seconds and then work again, or if I have bad luck; the mouse response shuts off completely (LEDs are on though) - temporary solution for me is to reconnect it.

 

But so far I had no issues related to Wireless.

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

i have the same issues relating constant stutter, connection issues 

On 5/31/2021 at 2:02 PM, C0lin said:

my mouse randomly shuts off for a couple seconds and then work again

aswell as this.

It's sad to see that the corsair support doesn't seem to care much about this issue. If this issue still persists in a week or two I will probablytry to get a refund and switch to a Gpro. for 100€ it's really embarrasing that we get something like this

Link to comment
Share on other sites

  • 3 weeks later...

I literally had skipping looking horizontally (most noticeable) and tried EVERYTHING else. 

IT TURNED OUT TO BE MY DONGLE PLACEMENT. 

It was originally in my back USB port of MB. I moved it to the hub to have it separated from every other USB connection/dongles and it fixed it instantly. Some sort of interference. 

Edited by sethpays
Link to comment
Share on other sites

  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...