Jump to content
Corsair Community

Corsair Void Elite Surround Premium not working with iCUE


Headsetispain
 Share

Recommended Posts

I just want to start off by saying I previously posted my original thread in the wrong category. So my problem is that when I plugged in my headset for the first time it was working. I had just recently bought it and was ready. Then I noticed that I was hearing my own voice through the headset. I could hear other audio but hearing my own voice got annoying. I went in to researching how to fix it and found nothing. Then I went to the manuals that came with the headset and found the iCUE download and got it. After I installed it I plugged in my headset using the included 3.5mm headphone jack to usb dongle that came with my headset and was greeted with the voice on the iCUE saying “headset off.” Then no sound was coming through and I tried to call my friend on discord and when he answered he typed in the chat that he could not hear me. I was confused and researched again to find nothing on what was happening. I tried everything I knew to do but could not find a solution. Could someone help me? Thank you
Link to comment
Share on other sites

  • Corsair Employees

The first problem you mentioned is actually a Feature called Sidetone. Some users find it useful, but in your case it can be disabled in iCUE by clicking the icon below the Sidetone slider on the Void Elite.

 

For the second, I would double check your Default Playback and Recording devices for Windows and your voice chat service. You can right click on the Speaker icon on your Windows system tray, select Sound Settings, select Sound Control Panel on the right, and set Void Elite to default on both Playback and Recording tabs. You'll go into your voice chat app and perform similar steps depending on the service.

 

if you run into more issues, you can also contact support: https://support.corsair.com/

Link to comment
Share on other sites

 Share

×
×
  • Create New...