Jump to content
Corsair Community

Trying to solve my issues with Scimitar Pro RGB


iFlandy
 Share

Recommended Posts

Hey everyone!

 

So, I am gonna get right down to it here.

 

I have a Corsair Scimitar Pro RGB, that I got from a friend and can't RMA.

 

There are a few things that happens with it:

Cursor randomly freezing for 1-2 sec when I move it around.

Lifting it will cause the cursor to freeze as well.

Sometimes the mouse will turn off, but Windows wont make any

disconnect sound until I unplug it, so Windows will still think it is on.

 

All of this started a few months ago, it was working fine until then.

It works fine in any other computer.

Any other mouse works perfectly fine in my computer.

 

I have tried every USB port with the Scimitar, but the issue is still there.

 

I honestly don't know what to do from here.

 

What I have done:

Fresh Windows 10.

Soft and Hard reset on the mouse with new firmware.

Had iCUE uninstalled and installed.

Turned off every other program running - Synapse, Afterburner etc.

Changed USB power settings.

Used it in USB 2.0, 3.0 and even tried with a 2.0 USB Hub.

Reinstalled USB drivers.

 

This is especially annoying since I have another Corsair mouse that works without any issues.

 

Is there anyone out there that have managed to fix an issue like this?

 

My PC specs:

 

Motherboard: MSI X470 Gaming Plus

CPU: Ryzen 5 2600 at stock clock

RAM: Corsair CL16 Vengeance at 2666Mhz - 2x8GB

GPU: Palit GTX 1070 Dual - Overclocked with Afterburner

Drive: Intel 660p 1TB

PSU: Seasonic Focus Plus 750W Gold

 

Other things:

 

Keyboard: Razer Blackwidow Tournament Edition Chroma v1

Mouse: Corsair Glaive RGB Pro - Currently, since Scimitar wont work.

Headset: Steelseries Arctis 5

Mousepad: Razer Goliathus Chroma

Link to comment
Share on other sites

We would recommend you reach out to our support team by opening a ticket at https://help.corsair.com

 

 

I have already reached out to you guys with a ticket, that is where I got the firmware from, so I could do a hard reset.

However, it haven't solved my issue.

So I wanted to reach out to the community and see if someone have

managed to solve an issue like this, before making a new ticket.

Link to comment
Share on other sites

 Share

×
×
  • Create New...