Jump to content
Corsair Community

K70 RGB MK.2 LP not detected on iCue start 50% of the time


cp_clegg
 Share

Recommended Posts

Roughly 50% of the time I turn on my PC, after Windows boots and iCUE starts, my K70 RGB MK.2 LP is not detected by iCUE. The keys function, but it is running RGB colors from the hardware profile since iCUE doesn't detect it at all.

 

If I unplug and reinsert the USB connections then it is detected by iCUE and everything works again.

 

This has been going on since I bought it and I have tried everything I can think of to troubleshoot this including the following:

  • Plugged into different USB ports, every permutation tried, including front and back USB ports, using USB 2.0 ports, USB 3.2 Gen 1, USB 3.2 Gen 2 and splitting plugging the two cables among those different USB ports/hubs as well
  • Wiping and restoring onboard hardware profiles
  • Force updating keyboard firmware
  • Resetting keyboard
  • Leaving iCUE Nexus disconnected from pass-through USB

 

I have an Asus RoG Maximus XII Hero motherboard and my system is loaded with corsair products:

HX850i PSU

Dominator Platinum RGB 32 GB (4 x 8 GB) DDR4-3200

H150i RGB Pro XT AIO

ML120 Pro RGB fans x9

Commander Pro

Lightning Node Pro

MM800 Polaris RGB

ST100 RGB

Void Elite Wireless RGB

Nightsword RGB

iCUE Nexus

K70 RGB MK.2 LP

 

This is all on a newly built system, fresh Windows install with nothing installed in Windows besides hardware drivers, iCUE, Chrome, Steam, and a bunch of games.

 

I need iCUE running because I rely on custom cooling profiles for my fans (and because I paid for pretty lights).

 

I'm real tired of having to replug my keboard half the time I turn on my PC. That along with periodic random iCUE crashes have made me somewhat regret my investment in Corsair hardware.

Link to comment
Share on other sites

  • Corsair Employees

Try double checking your BIOS for the fast boot setting and disabling it. This feature is known to cause issues with USB detection during the boot cycle. I would also reach out to our techncal support team for further troubleshooting steps in case you need a manual firmware reset of the keyboard.

 

https://support.corsair.com/

Link to comment
Share on other sites

Thank you for this suggestion. I have tried disabling fast boot and so far it definitely seems like it is helping with the detection issue happening less frequently. It still has happened a few times though. Is this normal for everyone or should I create a support ticket?
Link to comment
Share on other sites

  • 2 weeks later...

Well I did as you suggested and opened a support ticket. I followed support's instructions to the letter and it completely bricked my keyboard. It doesn't work at all anymore. It can no longer be detected properly by Windows even, no lights, no typing. Nor is it detected by any other computer or usable anywhere.

 

I assume support will expedite a replacement when they finally reply to me but I also have the issue of having mounted the Corsair Nexus to that keyboard using the provided adhesive mount. I assume I should also be receiving a replacement adhesive mounting bracket to attach my Nexus to my replacement keyboard because the adhesive on my current mount won't stick so well after being removed.

Link to comment
Share on other sites

Quick update: I was given the wrong firmware file. I can now use my K70 again after flashing again with the correct file. Now it just remains to be seen if the intermittent detection problems are also resolved. At the very least I once again have a functioning Corsair keyboard just in time for the arrival of my RTX 3090. I couldn't stand that $5 Dell keyboard another minute.
Link to comment
Share on other sites

 Share

×
×
  • Create New...