Jump to content
Corsair Community

iCUE v3.32.80 major problem - unable to start a PC cause of BSOD


MaGiieN
 Share

Recommended Posts

I've just registered to report that updating from iCUE v3.31.81 to v3.32.80 caused a continious BSOD on my PC with error code: ''INACESSIBLE BOOT DEVICE''. You can see it on the attached image. So the only way to boot my PC was to revert to previous iCUE version (v31.81) by loading Windows repair utility and using System restore.

Luckily there was restore point and my PC booted straightaway with no problem.

 

But imagine if there was no restore point for some reason or system restore was turned off. This means using more sophisticated utilities to boot a system and wasting a lof of time just to fix your mistakes. I've never had any serious issues with your software and I'm very surprised that simply updating iCUE could make a PC unable to boot.

 

I'm running Windows 10 Home 2004 x64 with all recent updates installed (19041.450). You can see all my specs in the profile.

I'm also using Corsair Strafe RGB MX Silent, Corsair M65 Pro RGB, Corsair MM800 RGB Polaris mouse pad and have installed 2x Corsair LL140 RGB fans, 1x Corsair LL120 RGB fan with Corsair fan HUB and Corsair Lighting Node PRO.

 

I should mention that during the update process corsair update utility asked me times to restart my PC although all previous updates never required a PC restart. When I agreed my PC restarted and there was no iCUE installed on my system, the update utility just simply removed the old version. I had manually to launch an installer which resulted again in multiple prompts to reboot my pc during driver installation. I pressed ''reboot later'' several times and after sucessfull installation I received again a prompt to reboot my PC. And voila, I've got a BSOD right after Windows boot screen and unable to boot Windows anymore. The rest of the story you know already.

1224944213_20200902_2314491.thumb.jpg.51953613d8493fb05586610569970e63.jpg

Link to comment
Share on other sites

  • Corsair Employees

Hi MaGi)(ieN,

 

I was working with Mint on this one. One thing can I have you try first is running a clean install of the latest version of iCUE which should be 3.33.246. You can PM me if you still have the same issue after.

 

How to do a clean install of iCUE: https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

 

iCUE Version: http://downloads.corsair.com/Files/CUE/iCUESetup_3.33.246_release.msi

Link to comment
Share on other sites

 Share

×
×
  • Create New...