Jump to content
Corsair Community

Corsair Scimitar pro side buttons don't work after restart


solkazo
 Share

Recommended Posts

Hey Everyone,

 

I just got my Corsair Scimitar pro and having major problems with it. Everytime I restart my PC the Corsair Scimitar pro side buttons don't work at all. I have to open the iCUE software, clear the profile, uninstall iCue and rebuild the entire profile thing and then it's a 50/50 chance of working...

This is my first corsair item and it's very disappointing how it's behaving.

 

I have tried different USB ports, updating windows, reinstalling iCue etc.

 

Firmware: V3.14 which is the latest for the mouse.

Software version 3.32.80.

 

Any help is appreciated.

Link to comment
Share on other sites

Alright, been fiddling about. It's a driver problem with the new software, I rolled back to iCue 3.20.80 and it's working fine. Limited with saving the profiles onto the mouse but at least the side buttons are working.. guess I will just use this version until something is fixed.. :/

 

Any Corsair staff checking in - Thew new iCue 3.32.80 when opening the software will hide the "Corsair Composite Virtual input device" in Human Interface Devices under device manager which I assume is essential to making your products work.

Link to comment
Share on other sites

Scratch above, woke up and the side buttons have stopped working again after the driver is disappearing after opening the iCue software - is this the quality of corsair products as a whole? Your software causes the hardware to stop working?

 

I don't have hours to troubleshoot a device each morning I wake up so I think I will have to return this and go with a Razer naga. Never am I going to be using a corsair peripheral product again, this is dreadful.

Link to comment
Share on other sites

 Share

×
×
  • Create New...