Jump to content
Corsair Community

Harpoon wired no works (When MK.2 is coneccted)


Ardjlon
 Share

Recommended Posts

In the last few weeks, I have noticed that the Harpoon device disconnects when starting windows, uninstalled drivers and iCUE and reinstalled, went back to previous versions and nothing worked. I thought Windows was the problem. But the problem is now when I turn on the PC, if I want to enter the BIOS for example, the mouse does not turn on anyway, it is as if it were disconnected.

 

Previously I had the STRAFE RGB MX Silent keyboard and Harpoon mouse; it didn't present that kind of problem. Now I have the STRAFE RGB MK.2 and the same mouse since for warranty reasons they gave me this other model.

 

I discovered about three days ago that the problem is with the new keyboard and only with the Harpoon mouse, I have tried other wireless and wired mice and have had no problems. It turns out that when I disconnect the keyboard and leave only the Harpoon mouse I have no problems, but I connect the keyboard again the mouse stops working.

 

I came up with plugging the Harpoon into the MK.2's USB port, and it seems to work fine, but it's not my idea to keep it plugged into that port, but directly on the PC.

Edited by Ardjlon
A better explanation of the problem.
Link to comment
Share on other sites

 Share

×
×
  • Create New...