Jump to content
Corsair Community

Unsure how to proceed with iCUE


Jorgonzolla
 Share

Recommended Posts

Hello, I'm at whits end here and hoping someone can be of assistance, since updating to windows 10 v2004 or whatever the latest is, I found that my mouse has started to lag when moved fast, at first I attributed this to my OS, so I wiped my computer and reinstalled the OS, everything worked fine at first until I installed the iCUE software, still, I wasn't convinced that it was causing the problem, I mean how can the software I have NEVER had an issue with cause so many problems so...I got in contact with the laptop manufacturer and we discussed it being a CPU over-heating problem, they came out 2 days ago and replaced the Mobo, CPU, GPU, Heatsink, Screen, RAM, just about everything but the shell. Once again, worked for a lil bit until i installed iCUE. I'm now 100% convinced that it's the problem.

 

I tried to downgrade to older versions (3.20, 3.19 and 3.18) and now all of these seem to be doing the same thing. Uninstalling iCUE stops the issues so I'm like 90% sure this is the problem, though I am not objecting to wiping the machine again with an old version of windows if needed.

 

I have turned down the polling on the mouse and this seems to work for a little bit but then eventually goes back to doing what it was doing, my conundrum is I rely heavily on iCUE and the ability to remap keys to my side buttons (looking at you shift and ctrl) and as I don't know another program that can do this I am a bit stuck.

 

A further explanation of the mouse issue is...If I move the mouse on the screen at a normal pace, it works fine, the occasional lag is barely noticable and I'm convinced I dealt with it in the past, anything above a snails pace though and the mouse sloooooows down then zooms to catch back up to where it should be, this makes playing MMOS almost impossible. Is this an issue with windows or an issue with iCUE?

 

Lappo is an Alienware 17R4, mouse is a Corsair Sabre. DPI is always set to 1500, never changing from that but since either updating one of the two, it can't hack it no more. Hopefully someone can help me either diagnose this or fix it :(

 

Edit 20/8 +4 hours: I reinstalled iCUE because ultimately I need it and can find ways to minimize the lag. I noticed once I opened iCUE the lag stopped, almost instatly and I was unable to replicate it, I closed iCUE back to the icon bar and it was back...the dreaded lag, reopened iCUE and bam...no lag? version is 3.19.120

Edited by Jorgonzolla
Version update and issue update
Link to comment
Share on other sites

I found that my mouse was not right clicking. I have had this problem before and never really worked it out. However, this time I noticed it would be triggered usually by unplugging the Dark Core SSE from wired to wireless. Sometimes just on it's own.

 

The issue seemed to resolve itself for most part though I was never really able to click within corsair iCue. At least I was able to interact with Windows again...until updating to Windows 10 2004. The issues has been non stop.

 

I figured I would uninstall and reinstall Corsair iCue. Well, I did this during a hang up where I was not able to really interact with Windows, especially system windows. I couldn't drop down folder in start menu, click about in settings app, etc. Managed to get it uninstalled however and BAM Windows snapped right back to its normal self.

 

So surely maybe it was just bugged right? Reinstall? Sure.

 

Well not long after it happened again. I noticed I couldn't open windows settings in, time was stopped and hadn't moved for 4 hours, a chat program hadn't updated the conversation in awhile. However, windows still was running. Surely Explorer is busted? Opened task manager and tried to restart Explorer...it suspended itself, flashed, never put night shade back on, and 2 windows explorer lines were in task manager now and time still was 4 hours behind. So I started searching through for anything from corsair I could end in task manager. I noticed "Corsair LLA" had a sub item that mentioned interactive so I ended that...low and behold Windows snapped right back to it's normal self and time was updated and all programs that were lagging updated. So the fault is with Corsair LLA, at least within my system. The worst part is LLA supposedly stands for Low Latency Audio and I use corsair for nothing to do with Audio. I really wish I didn't have to install this part.

 

Try ending Corsair LLA on your machines next time through task manager and see if it makes a difference.

Link to comment
Share on other sites

 Share

×
×
  • Create New...