Jump to content
Corsair Community

Corsair Scimitar RGB Elite - Keymapping/Shift Issue


Guacuhmole
 Share

Recommended Posts

UPDATE: UPDATED QUESTION ABOUT BYPASSING MODIFIER/SHIFT ISSUE LISTED IN NEWEST POST. SEE THERE FOR UPDATE. I AM RUNNING ON A MAC COMPUTER AND AM TRYING TO BYPASS LIMITED FUNCTIONALITY OF MAC ICUE SOFTWARE. PLEASE SEE BELOW.

 

System Info:

 

2018 Macbook Pro running 10.15.6 Catalina

6-Core 2.9 GHz Intel Core i9

Radeon Pro 560X 4 GB GPU

 

Hi, I sent a ticket to corsair support about this but in the case they don't get back to me I'm going to post this here too because I am extremely exasperated.

 

I am having an issue with the scimitar elite; I am only trying to do one thing: Bind my middle mouse button, to shift. That's it. I want my middle mouse button to behave as the shift button, and to modify all my side buttons accordingly. I.E., when I press middle mouse button, and side button 1 (mapped to normal 1 on keyboard, not numbed 1), it registers as shift + 1. I cannot figure out how to make this work in the software, I have tried the following, but it will range from just not working to completely crashing my computer. It seems like a pretty simple thing to have such dramatic effects on my computer, but that's software, so I digress. Probably helps to explain that I am trying to use this as a modifier button for wow, so that essentially I have access to shift on my mouse and don't have to worry about triggering it with my left hand.

 

Tried all of the following in the "Actions" Tab of iCue.

 

- Tried using a macro that presses and releases shift. Figured out this does not work, because it doesn't function as a modifier button but only as a short keystroke of shift.

- Tried searching for shift in the various lists that they have in iCue, could not find it (or control, alt, anything of that nature which I was hoping to map to other mouse buttons) anywhere

- Tried mapping shift as a keystroke under middle mouse button, but upon doing so, not only did it not work, but upon pressing the middle mouse button after this mapping, every single time, my computer froze, and I had to restart it, every single time.

 

I don't know if I'm just an idiot, if I'm missing something very obvious, or if there's something just wrong with the software/there are limitations I don't know about, but it seems absolutely ridiculous to me that something as simple as this is so difficult. I read about people attempting much more sophisticated and complex macros than assigning shift to the middle mouse button. Seems to me it would be one problem if I could get it to work as shift but not with the other mouse buttons, but I can't get it to work at all.

 

Isn't it kind of conspicuous that all of the modifier keys are absent in the keybinding section of the software? Is there some computational limitation I'm just missing here? Like seriously man, I am not asking for much out of this mouse. Like I have all the side buttons assigned to numbers, and at the bare minimum, I want the middle mouse button to perform as a shift key. That's it. Nothing else. Forget control, forget alt. I will take just the shift. It doesn't seem like it should be this difficult, but, once again, maybe I'm just missing something super obvious.

 

Is it a configuration issue? Am I not "assigning" the shift button properly? Because if there's another way it's just not very obvious, at least not to me.

 

What the concerning thing really is for me is that it's crashing my computer, button functionality aside. Like I'm pretty careful not to do stuff to my computer that's sketchy, or will damage it. And I would not thing assigning the "programmable mouse buttons" to press a standard button on a computer keyboard would lock up my entire system.

 

Anyway, I am very very frustrated, if that was not already obvious. I just really want to resolve this issue because it seems like it should be very simple and that does not seem to be the case. Like I'm just really baffled that such a simple function is so damn complicated to get right. If you're reading this Corsair, please just make the modifier buttons readily available in iCue and preconfigure them to work properly, because I imagine that would be a lot easier for people than people potentially breaking their computers.

 

Alright, rant finished.

 

Please for the love of God, if you know the solution to this problem, I'm banging my head against the wall here trying to figure this out. But help would be much appreciated.

 

Maybe I'm just a noob but help me out please and thank you <3

Edited by Guacuhmole
Link to comment
Share on other sites

I will add, as well, that I do not have the submenu that you included in your attachment image, "Remap Modifiers and Lock Keys". That submenu is not present in my iCue software. However, it says the software is up to date. That may be the source of the problem. Do you have any idea why that might be?
Link to comment
Share on other sites

Hi,

 

I am posting this here again to reiterate, but my iCue software does not have the "Remap Modifiers" tab like in the screenshot posted. It is not present. Once again, if anyone knows why this is, I would really appreciate it and I think it would point me in the right direction. Thanks so much, again.

Link to comment
Share on other sites

I have a follow-up/updated version of this post:

 

I would like to clarify again that I have a Mac Computer; it is powerful enough to run the mouse peripherals, specs listed in Original post. However, I have in my House a windows desktop. I'm realizing that on the Mac version of the iCue software modifier mapping may not be available...

 

Is it possible that I could create the middle mouse ---> shift action on the windows as a hardware action, doing so on the windows computer, and then just plugging it into the mac? I feel like this could work for bypassing the limitations of the mac software. At the same time, I feel like it could completely explode my computer like I described it having done above in the original post. Any feedback? Thanks

Link to comment
Share on other sites

  • Corsair Employees
It does but you are working in the HARDWARE ACTIONS tab instead of the ACTIONS tab like my screenshot i provided earlier. You are limited to what actions can be created when using the Hardware Actions tab as any action made there is intended to be saved to the onboard memory of the mouse for use when iCUE is not running.
Link to comment
Share on other sites

 Share

×
×
  • Create New...