Jump to content
Corsair Community

Void Wireless Headphones - Worst I've ever had


kurdain
 Share

Recommended Posts

So I bought these quite a few years ago and since I rarely ever get fired up enough to post or complain about something I felt this was finally time after 5'ish years of wanting to smash these into pieces.

 

The first pair didn't work well at all and I remember a tech on the phone walking me through updating the firmware and it bricked the headphones.

 

They sent another pair after a while (this was years ago - exact details are fussy). These headphones worked OK but were a lesson in frustration even from the first day.

 

They frequently won't connect, especially if you already have something playing...say a game or YouTube. You'll turn on the headphones and you wait and wait...10-15 seconds...minutes. 100% of the time if you get impatient and turn off the headphones to try again they'll start working milliseconds before powering off and you get to start the power on and random wait all over again.

 

The mic constantly gets stuck in mute, red light on...no one can hear you but you can hear fine. No amount of button pushing will resolve it. About 10% of the time turning off and back on will resolve it, 10% of the time unplugging and plugging back in will, 80% of the time it's a hard computer reboot to get them to work again.

 

Once you reboot then you get to fiddle with the procedure above to get them to work.

 

I tried plugging directly into the computer, using the provided range extension cable, moved the x-mitter all around my desk (in case it was a signal thing), I've uninstalled, reinstalled, uninstalled, reinstalled, reboot, safe mode, clear registry, reinstalled, re-re-re-re-flashed firmware probably dozens and dozens and dozens of times over the 5'ish years. SAME behavior even after a fresh windows install when I updated my PC.

 

I will NEVER buy anything other than memory from corsair again...love their memory but these headphones after so many years of anguish over something so simple...

By far the worst peripheral I've ever owned, headsets or otherwise.

 

Well tonight....they got stuck...again...muted...nothing worked...reboot...power on/off...nothing....permanently 'disconnected' no matter what.

 

I finally went office space on them...and what a feeling.

Link to comment
Share on other sites

 Share

×
×
  • Create New...