Jump to content
Corsair Community

Nexus - What a shame...Limited function and creating issues in my setup.


Beretta911
 Share

Recommended Posts

I received my Nexus yesterday and well...I'm pretty disappointed. As already noted there is very minimal functionality at launch, the documentation on how to do anything is terrible and to add insult to injury, some of my other Corsair components are now having "issues". I get that this is a new device and further functionality is still to come, but c'mon guys. We should have some profiles already built out for the largest games and use cases (GPU usage? Geforce Experience?). How about even a touch screen button to cycle through my iCue profiles or assign a button to specific profiles? I can cycle through them with my K95 but I was hoping to be able to assign specific buttons to specific profiles. It may be possible, but damn if I have any idea how to do it and frankly seems like low lying fruit for the dev team to have at built out as a widget at launch.

 

But I'll leave that there for the moment. I'm (or I least I was) prepared to wait for it to mature a little...

 

The biggest functionality issue is that I keep losing connectivity/functionality to my other devices. Previously I did not have any issues - and am using a K95 keyboard, a sabre mouse, void pro wireless, (2) MM800 mouse pads, ST100RGB towers, H100i Pro, Vengeance RGB memory, and a LS100 and Lightning node pro with 6 LL120 fans. So yeah - big investment in Corsair RGB. So I add the Nexus into the mix (on its OWN usb port) and suddenly I'm now losing connectivity to the MM800s after a few minutes. Sometimes its my K95... I've moved them to their own USB ports (I have the Sabre mouse plugged into one of them, the other also has a Griffin Powermate plugged into it) and still the same issue. iCue is buggy now and will crash out when trying to configure devices. Even now as I sit here, one of the MM800s just went into offline mode. Unplugging it from its USB port and plugging it back in seems to fix it for a while but guys - I'm not prepared to have one device cause me issues in my setup. I'm going to keep it for another few days and see if there is something I'm missing or a config I can try to at least get it stable but if not I'm afraid I'm going to have to return it. Obviously I'm a huge fan and have become a bit of a iCue power user, but this is disappointing. Too bad - I was dummy excited.

Edited by Beretta911
Link to comment
Share on other sites

QUestion: did you update iCUE at the same time as you installed the Nexus?

 

TBH - I've had the Nexus for a while. I have a good deal more RGB than you do and know others that also have a good deal more. No random disconnects here. 3.31 does have some issues but not sure if that'd be related.

Link to comment
Share on other sites

 Share

×
×
  • Create New...