Jump to content
Corsair Community

iCUE and Nexus not playing well together


LittleLuci
 Share

Recommended Posts

Hi All,

 

I've had my Nexus a few days now and it worked fine for the first 2/3 days. I managed to set up some custom screens, and the screens displayed correctly. Until today...

 

So here is the issue and the few things I've noticed.

 

1. When I boot my PC the Nexus turns on and I can see the animated "screensaver with the white Corsair logo"

2. When I log in and the iCUE services start the "screensaver" animated display pauses (don't get the particle and colour changes anymore, like it did before log on)

3. In the iCUE software, the Nexus is detected in the softwre however all my screens (my personal ones and the buildin ones) are missing.

4. The Nexus can be seen in the device list from the home screen in iCUE, but when i click to another device (or on the Nexus itself) it disappears from the top bar.

5. I also cannot interact with any settings on the Nexus config screen. IE: The plus button does not respond so I can't add new screens.

6. Restarting the PC or even the service in the iCUE software has no effect.

7. All my other Corsair devices (of which I have many) all show up correctly and work as expected.

8. The only way to get it to work correctly is to reinstall the iCUE software. However after 1 reboot, it goes back to not displaying the screens anymore.

9. I am running the latest version of both firmware (2.2.5) and iCUE (3.31.81) as of posting this thread.

10. The Nexus is plugged into my K70 MK.2 LP keyboard.

 

Have any Nexus owners seen this before? Is it happening to anyone else?

At this stage I don't think the hardare is faulty but rather that the iCUE software is having a moment.

 

It possible that a software update may resolve the issues but just wanted to see if I'm alone with regards to this issue.

 

I have attached some screenshots to show the issue.

 

Any feedback would be greatly appreciated!

 

Thanks guys! :D:

801721612_icue1.thumb.PNG.4295aeeb911ee1b08bed14395693c2c1.PNG

500394982_icue2.thumb.PNG.79fba2d143e93e99342fa15260d4f291.PNG

186965734_icue3.thumb.PNG.7d7eb22f15a3db7e939c9f626063603b.PNG

1251953970_icue4.thumb.PNG.5c4d5b67ef544bce0ca8784cd0de7870.PNG

Edited by LittleLuci
Link to comment
Share on other sites

Have you tried closing out iCUE with the task manager and reopening it? Also check for any updates to the iCUE software.

 

Another possibility is how you're connecting it to your computer. I tried using a USB extender so that I could mount the Nexus to my Logitech Keyboard's USB passthrough but the extender was apparently just sending power to the Nexus but wasn't allowing data transfer. A new cable fixed this for me. Is this possibly your issue?

Link to comment
Share on other sites

  • Corsair Employees

Try moving the iCUE NEXUS to a different USB port on your system. If it's plugged into the passthrough on your keyboard, try moving the other end of the passthrough to another port so you can keep the iCUE NEXUS plugged into your keyboard.

 

Have you contacted our support team? They may be able to better assist you: https://support.corsair.com

Link to comment
Share on other sites

  • Corsair Employees
I'm having issues with mine as well. I can't get the starter pack to load and icue keeps crashing on me.

 

After unzipping the starter pack file, you may need to change the extension of each ".cuescreens.zip" file in the folder to just ".cuescreens" which should then import into iCUE.

 

Related thread: https://forum.corsair.com/v3/showthread.php?t=198489

 

As far as the crashing goes, you may need to update/reinstall iCUE but if the issue persists, please contact our customer support team at https://support.corsair.com

Link to comment
Share on other sites

 Share

×
×
  • Create New...