Jump to content
Corsair Community

Corsair iCue crashes 1 second after it launches, need help!


Rashad
 Share

Recommended Posts

Hello dear forum reader,

 

 

 

I have the Corsair spec omega rgb case that comes with Corsair rgb things.

 

The problem is that its currently stuck on rainbow orgasm since i cannot open the Corsair iCue software.

 

I tried installing it but when i go ahead and open it, the software closes again immediately (I see a process run in task manager but it closes immediately, in less than 1 seconds).

 

Ive looked all around the web for answers and tried the following to solve it myself:

 

Reinstall the software

Delete all files associated with the software and reinstalled

Tried another usb header inside my case

Unplugged the 2 fans + case rgb and plugged only 1 in at a time

Installed an older version of iCue

Installed the old Link software, i can open that but its no use to me

Yelled at the pc

Run the program as administrator

Run the program in compatibility mode

But nothing seems to work.

 

 

 

My specs are:

 

 

Motherboard: MSI Z390 Gaming Trident X Plus 9SF-087EU (MS-B926) Micro-Star

Processor: Intel® Core i9-9900K CPU @ 3.60GHz (16 CPUs), ~3.6GHz

Memory: 32 GB DDRAM

Display Devices: NVIDIA GeForce RTX 2080 Ti

Monitor : MSI Optix MAG272QP 27" 165Hz 1ms FreeSync QHD

Operating System: Windows 10 Pro 64-bit (10.0, Build 19041)

 

 

 

Can anyone help me in my frustration?

 

 

 

Thanks already for any help!

Link to comment
Share on other sites

 Share

×
×
  • Create New...