Jump to content
Corsair Community

All SDK Effects in FC New Dawn have both Front and Rear turned off (for QL)?


SgtStenen
 Share

Recommended Posts

Am I the only one where all the effects in Far Cry New Dawn is black?

 

After switching my fans from LL to QL (and switching to the included Lighting Node Core) the SDK effects stopped working in FCND, but were fine in other games.

 

After some digging around I imported one the profiles FCND_Menu.cueprofile into iCue and noticed that ALL the Lighting Channels in the profile have both Front and Rear turned off. Changed that in iCue, and exported the file back into the correct folder and *poff*, now That specific profile work in the gaem.

 

Am I the only one with this issue? Is there a fix in the works, or a, I suppose to fix all 57 profiles manually?

Link to comment
Share on other sites

others have noted this, but they released the fans after the profiles were made (by I gather, not Corsair, but the probably game dev - Ubi and whichever studio it was - I have the game by the way, loved it but just uninstalled it yesterday).

 

I wouldnt normally advise this but I bet any amount of money a straightforward regex replacement or xml parser would do what we need it to on those 57 profiles.

 

Can you post a before and after profile so we can compare the differences and then come up with a script to automate this? I don't think it would be difficult, and I imagine it could be used or tweaked again for other titles or future ecosystem releases.

 

EDIT: C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\GameSdkEffects\Far Cry New Dawn\ I would do it, but i dont have either fan product and the demo ones introduce some funky profile characteristics if I recall.

Link to comment
Share on other sites

It appears the small sample size I looked at gave me the wrong idea. The profile FCND_Menu.cueprofile just had the F/R turned of, but now that I have looked at more profiles in the Far Cry New Dawn SDK-folder most of them just have nothing in their Lighting Channel.

 

I could swear that I looked at FCNC_Day and FCNC_Night as well yesterday and that they hade the Front/Rear issue, but both of those also have empty Lighting Channels now.

 

The first two profiles I looked at today (FC_Takedown and SDKL_Alarm) both had partial LEDs selected, the first 96 LEDs from the top left, eding in the Rear side of the 3rd fan. All profiles I have opened after that are blank. I'm starting to feel like iCue are changing and adapting to my efforts as I go :D

 

EDIT: OK, something fishy is going on! I am 100% sure that yesterday I looked at and fixed the profile FC_Benchmark, since it was an easy profile to check if it worked. It had the problem with Front/Rear not on, and I changed that. Today the Lighting Channel if that same profile is empty... WHAT is going on?!

Edited by SgtStenen
Found more information
Link to comment
Share on other sites

I might just add that before I changed my setup from RGB Lighting Hub + Lighting Node PRO, too just an Lighting Node CORE, all effects in Far Cry New Dawn was lighting up but only the first 96 LED:s on my 5 QL fans. When I switched over to Lighting Node CORE they all went dark...
Link to comment
Share on other sites

not to be a 'tech support jerk' but out of curiosity, you exported the tested profiles when you would make edits and then copy them into the folder? For most people, that is actually fairly difficult with UAC, you usually have to save them elsewhere and copy them in and elevate to allow them into that directory. Just wanted to add that, but I am afraid I cannot comment on much else as I dont have that particular equipment.

 

Still think there's a fix here though, its probably not too complicated once we know what to look for.

Link to comment
Share on other sites

 Share

×
×
  • Create New...