Jump to content
Corsair Community

iCue 3.31.81 "Bring to foreground" slow/not working


Recommended Posts

Hello,

 

Lately I have been having issues getting iCue to bring up the dashboard. In the past I have been able to right-click the iCue icon in my system tray and click "Bring to foreground" and the interface opens right up. Recently however, this process has been painstakingly slow. It takes several minutes to display the dashboard. Additionally, once it does open up, switching to the "Settings" tab takes another several minutes making it difficult to install updates to the software itself or device firmware. I have tried uninstalling/re-installing (removing profiles as well) to no avail. I saw in a thread from a couple years ago that the issue resulted from custom scaling or something. The post wasn't detailed enough for me to discern which specific settings were the culprit and how they fixed it. If anyone has any advice on how to mitigate this issue, I would greatly appreciate it!

 

EDIT: This started before I updated to 3.31.81. I am not sure exactly when this started to become an issue...could it have been when I updated Windows to version 2004? I haven't added or changed any devices that the program controls (no new mouse, keyboard, fans, etc.).

Edited by zlozier
Link to comment
Share on other sites

I am going to second this, but I have to tell you it has been in most iCUE v3 releases for me. I have a lot of icue products but nothing has any type of delay anywhere else, but the bring to foreground takes forever which tbh isnt a big deal but it does take a full 3 - 4 seconds or more to even start to display and then even longer to enumerate the profiles at the left (and this is on more than one, quick systems - one of which is 8700K@5Ghz alongside 5Ghz ram launchine icue from a typical SSD).

 

I have to imagine this is a delay on account of it polling the entire system, just like when in windows you open device manager - it takes a bit to poll and confirm everything is complete and up to date. I think they could fix this with any of the following:

- Cache what items the system had in place already, and display that first

- At a minimum, tell the user who clicked bring to foreground, yeah hey we are working on it and here is a blank screen with a timer or progress bar, or what we think could be connected to the system

- Expand the SDK or provide a CLI to change profiles within icue (natively) without requiring button presses from a corsair product. This would reduce cases where users who already set everything up need to actually bring icue to the foreground at all.

 

EDIT: Just updated to newest release. Next reboot, took a good six seconds to show page. I said to myself, well i just updated, maybe that means something different. Closed iCUE and tried again, this time it was cached or whatever and it only took like 1 second. Still not superfast, but that is news to me and actually may have been addressed since I dont recall that behavior (where it was suddenly fast on second attempt, but I guess I cannot dispute if that was fixed earlier as I may have only ever found myself doing that once per boot...YMMV

Edited by hastegag
update
Link to comment
Share on other sites

  • 2 weeks later...

...could it have been when I updated Windows to version 2004? I haven't added or changed any devices that the program controls (no new mouse, keyboard, fans, etc.).

 

I had a problem with many programs, including latest versions of iCUE, MS Edge browser, MS Weather, Netflix, MS Store, AMD Radeon Settings and more all taking 12-20 seconds to open when all used to open immediately to 3 seconds at most. This all happened when updating to Windows 10 2004 using the Windows Update utility in settings, every time, 3X from May-mid-July. I reverted back to W10 1909 and programs opened quickly.

 

I have since performed a fresh install of Windows 10 2004 using the Windows Media Creation Tool via USB and all programs open quickly again as they always had in 1909 and previous versions of W10.

Link to comment
Share on other sites

  • 2 months later...
Hey y'all. Been a hot minute. I'd like to update that I tried installing a previous version posted (3.30.97) which did not solve my problem. I've been procrastinating doing a fresh Windows install, but it appears that will fix the issue. I'll post another update once I do that...probably in another couple of months haha
Link to comment
Share on other sites

  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...