Jump to content
Corsair Community

Another ICUE disappeared question...


Jaxon
 Share

Recommended Posts

I updated my ICUE software today and naturally I had to reboot. I noticed my K70 was in one of the default rainbow modes but my RAM and i115 RGB AIO still retained their settings. Tried to open ICUE and its just gone, the file is still there but its empty. Tried to install it again and still no luck. In my ProgramData folder I can see that I first installed ICUE on Feb 15, 2020. Is there a way I can find the version I would have installed on that day? It would have been the latest version at the time as that was the day I finished my build.
Link to comment
Share on other sites

I can't promise you anything, but the posts on the forums ought to help you correlate it to February 15, 2020. You can always change the version number in the download url and they keep them available online:

 

http://downloads.corsair.com/Files/CUE/iCUESetup_3.31.81_release.msi

http://downloads.corsair.com/Files/CUE/iCUESetup_x.xx.xx_release.msi

 

 

Looks like it might be iCUE v3.24.52 as of 2-15-2020 (seen here https://forum.corsair.com/v3/showthread.php?t=194049) but no guarantees.

 

That being said, that is probably not going to help, I would not roll back, theres a ton of other diagnosis stuff to try. I think some people try disabling full software control. You sure your K70 isnt using a hardware profile?

Edited by hastegag
Link to comment
Share on other sites

 Share

×
×
  • Create New...