Jump to content
Corsair Community

Slow WRITE Speed Force MP510 1920GB


Recommended Posts

Had the drive for just over a year. Noticing reduced write speeds.

 

My PC specs are up to date in my profile.

 

- Running firmware ECFM12.3

- Monitored SSD temperature, did not pass 43c during test

- TRIM is enabled

- MB BIOS up to date

 

This is the drive as of today:

7XkkVYQ.png

---

This was the drive when I first installed it:

aPCpFDg.png

 

---

Some other tests as of today:

https://i.imgur.com/6mX2z2d.png

https://i.imgur.com/BI9tIuP.jpg

https://i.imgur.com/lc685AU.jpg

Edited by Tarv
Link to comment
Share on other sites

Support asked what the free space was, I said it was 60% full. They then said my question was being sent to another department.

 

As a test, I tried removing a large amount of data from the drive and putting it back on. Here were the tests:

 

1) Starting test:

6mX2z2d.jpg

 

2) Removed over 400GB of data, expected speeds returned:

AMTM62G.png

 

3) Added some data back (call it folder 1), speeds are gone:

dzXTCsP.png

 

4) Added more data back (folder 2):

x4AtlXY.png

 

5) Tried removing data put back in step 3 (folder 1):

LulRx1P.png

 

6) Left it for a few days, a few reboots, etc...:

Hh5SaEJ.png

 

---

 

Not sure if it's the expected results of the speeds to disappear at that capacity, or if the drive is defective.

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
  • Corsair Employees
adnotacja-2020-09-12-095528.png Here are my results on MP510 960GB. If you need more info, lemme know.

 

Thanks for sharing, I've forwarded this to our product team.

 

I don't have access to the drive at the moment, but as far as CrystalDiskInfo stats I can say.

 

Trim was enabled

Temperature was where it should be

No SMART stats jumped out

 

Thanks for the additional info, our product team seems to want CDI screenshots to help troubleshoot on their end so feel free to provide that when it's most convenient for you. Their initial assumption was temperature, but I've noticed that doesn't seem to be the case as you've found. We're investigating and I'll provide updates when I can.

Link to comment
Share on other sites

  • 3 weeks later...
  • Corsair Employees
Its gone 2 weeks now and no update since then ???

 

Correct, no updates yet. Our product team is still investigating. Part of the process involves working with our tech support team to gather further information which takes some time, so please continue to work with our support teams in the mean time.

Link to comment
Share on other sites

  • Corsair Employees

For anybody experiencing this still. Could you post results before and after disabling fast startup within Windows? Please let me know your results in the responses.

 

To disable fast startup within Windows, do the following:

 

attachment.php?attachmentid=39262&stc=1&d=1602522174

 

attachment.php?attachmentid=39263&stc=1&d=1602522179

 

attachment.php?attachmentid=39264&stc=1&d=1602522183

 

attachment.php?attachmentid=39265&stc=1&d=1602522190

 

attachment.php?attachmentid=39266&stc=1&d=1602522194

 

attachment.php?attachmentid=39267&stc=1&d=1602522213

Link to comment
Share on other sites

Same problem with Force MP510, firmware 12.2

SEQ 1M Q8T1 2100 MB/s Write

 

after the firmware update 12.3 It wont go over 620 MB/s Write.

 

Problem happened just after the update of firmware.

 

Is it possible the firmware 12.3 needs the version 2004 windows , I am on 2003

12_2.jpg.b988bab817e01c416140941f0454b6f0.jpg

12_3_1.jpg.b1419b82de9186f375fe1b364c745563.jpg

Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees
I also have a huge writing speed Issue I am on Asus X570-P with Ryzen 7 3700x And hardly get 300MB/s writing speed. Is there any solution yet?

 

http://i.epvpimg.com/Xg0Dfab.png

 

Your issue is most likely due to how full your drive is as performance and speeds will go down as free space decreases. This is a downside to NAND storage devices.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

If anyone from the SSD team wants to reach out, I also encountered this problem, but my MP510 960GB is currently sitting unused and I can run whichever diagnostics you want on it.

 

I only got the write speeds back after a zero-fill, fwiw.

 

Let me know if I can help diagnose this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...