Jump to content
Corsair Community

H150i RGB Pro XT USB connection not being detected.


Recommended Posts

I've seen a few posts like this and have tried what else was listed (shout out to DevBiker for being the expert here), but nothing has worked.


I recently built a new PC. Everything is working great, with the exception of the H150i RGB Pro XT. I have the pump connected to the AIO pump header on the board, and connected to SATA power, and 2x ML120 fans connected to the fan connections from the pump. It is functioning well, however it is not being picked up by iCue or, at least as far as I can tell, by my PC at all. I tried many solutions I found on the Corsair forums. I have the USB connection securely placed in the pump, and have tried connecting it through the Commander Pro, each of the board USB headers, and to two different PC's through USB. No matter what I do, none of the PCs ever pop up "new device connected" or anything like that, so I believe the USB connection on the pump may be faulty.


I saw Aura RGB may interfere, but even on the PC without that software, nothing ever registered. Is there anything else it could be?


USBDeview attached and specs below.


OS: Windows 10 CPU: Intel 10900K MOBO: Asus Z490-E Gaming GPU: Asus 1080 Ti OC Case: Corsair 465x Ram: Corsair Vengeance Pro RGB 32gb 4000mhz PSU: HX1000i Fans: 6x LL120, 2x ML120 Fan and LED controller: Lighting Node Core, Commander Pro



Link to comment
Share on other sites


  • Create New...