Jump to content
Corsair Community

Help with dual 5K screens


symphonik
 Share

Recommended Posts

Hi all —

 

I just got the CORSAIR ONE i164, what a marvel of engineering. Such an awesome machine.

 

For my Mac desktop I have dual LG UltraFine 5K screens, and it’s important to note that they are the -B model which supports display over USB-C, not just Thunderbolt.

 

I plugged both into the CORSAIR ONE via bidirectional DP-to-USB-C cables, as recommended when connecting to DP on this screen. Note that Windows and the DisplayPort implementation means the screen only runs at 4K, but that’s fine for my purposes.

 

So the behavior is strange on the CORSAIR ONE: I have both screens plugged in. When I boot, the first screen turns on and displays the CORSAIR ONE logo and BIOS prompts and whatnot. As Windows loads, that screen shuts off and the second one turns on. Windows continues to boot no problem.

 

I can never get BOTH screens turned on. Only one works at a time. This seems weird as I know the CORSAIR can drive three 4K screens, one on each DP, it seems like it should be able to do 2!

 

Even stranger:

- Windows does not detect the second display

- NVIDIA Control Panel DOES detect it, but when trying to configure it in Multiple Monitor setup, nothing happens when I click the checkbox for the screen

 

Things I’ve tried:

- Update NVIDIA drivers

- DDU and clean install of NVIDIA drivers

- Different cables

- Swapping ports around

- Lowering the resolution of the first screen

 

Always I can only get one to turn on at a time. But the one looks great!! ;)

 

Any ideas? And again I am totally cool with them not running 5K, the 4K on the main screen looks great.

 

Also, is it true the 2080 ti inside actually has a USB-C/VirtualLink port and is just not passed through to outside the case? I’ve actually heard these screens can be driven well off those ports since they are naturally USB-C.

 

Thank you!

Link to comment
Share on other sites

I also thought that there was a USB C that wasn't passed through to the outside.

 

At least my model, a100 with 2080 SUPER, there is no USB-C port on the graphics card. This is a custom model made exclusively for the Corsair ONE systems.

 

The system does indeed support multiple high resolution, high refresh rate monitors... I am running one 1440p monitor over DisplayPort, one 4k over DisplayPort, and a third 4k over HDMI (Using the third DisplayPort for Oculus Rift S)

Link to comment
Share on other sites

I'm assuming you moved the gable from working monitor A to non-working monitor B?

 

It really sounds like this may be an issue with Windows, the hardware seems to be working fine.

 

Unfortunately, support for these systems is really bad. Support takes 5 days (literally) to reply, and doesn't take the time understand the issue. I've been having an issue with iCUE not turning on the fan, and support told me to reset the CMOS with a button that doesn't exist on my model.

 

When I replied and told them this, it took them another 5 days to replay with

 

'Seems that your system may be using the fan more often because there is more heat in your system that needs to get rid of, was there temperature change in your environment? '

 

This particular forum seems mostly dead, I've seen one Corsair employee in here commenting once in a while.

 

The the cherry on top is that Corsair will not sell replacement parts for this machine. Once you are out of warranty, you are out of luck. Most of the hardware inside is custom for this machine. The motherboards are even running custom BIOS, which leads me to believe even those have some custom modifications.

 

Buying a product at a premium cost, you would expect premium product and premium support for that product. That is not the case with this system

Link to comment
Share on other sites

@Azureblood2, bummer to hear about the support issues. I agree, that’s astounding for such a major expensive purchase from what seems to be a super competent company. Sigh. I wish I’d read this before choosing the Corsair over the MSI units.

 

Yeah, and I have swapped the cables out. And again, both screens work (they both light up at different points), but it seems like it’s not able or willing to drive both.

 

I’ll hit up NVIDIA support, but man, Corsair folks, you must have some pointers...

Link to comment
Share on other sites

That's a great idea, @Azureblood2 -- I just tried it with another LG 1080p (DisplayPort to DisplayPort) and it worked fine. So in this case the configuration was:

 

1 LG 5k (on one DP)

1 LG 1080p (on another DP)

1 DP still open

 

And it worked fine. So at least eliminates the theory that it's struggling to support two of any monitor. Can't tell if that's progress or not. ;)

Link to comment
Share on other sites

It's worth showing a screenshot of what the NVIDIA control panel shows. It's so frustrating that it sees the 2nd screen -- but I can't select the checkbox. There's no error, it just won't select.

 

So, showing:

1. The two screens shown in "Multiple Displays" (but I cannot select the checkbox next to the 2nd screen)

2. The two screens shown in "Configure Surround, PhysX"

3. The "Change Resolution" pane which shows that the active LG 5k is (1 of 2), but doesn't actually show the 2nd display

4. The Surround setup which shows the two displays, but notice the "Connection Error" -- this prevents me from clicking "Enable Surround" or "Apply", they remain greyed out

 

1.

NWNr3yD.png

 

2.

s52JpZ1.png

 

3.

fhhDVR8.png

 

4.

GvfHqWe.png

Edited by symphonik
Link to comment
Share on other sites

That looks like you are telling the driver to merge them into one monitor and it is failing to connect to one of those monitors

 

AMD calls this Eyefinity... apparently Nvidia calls this nView

 

Try disabling this completely and see if two monitors appear in the windows display settings

Link to comment
Share on other sites

@Azureblood2 Amusingly the Connection Guide link goes to this URL which just redirects to the GeForce home page: http://www.geforce.com/hardware/technology/surround/system-requirements

 

:P

 

The "Surround" setup was really only me seeing what the driver is able to detect, but I don't have it turned on. It's an interesting idea to see if I can disable something on the NVIDIA side just get Windows to see both screens, so I might play with some things there.

Edited by symphonik
Clarification is good
Link to comment
Share on other sites

For those of you following at home, I was able to confirm that my CORSAIR ONE i164 has this card installed: https://www.techpowerup.com/gpu-specs/gigabyte-rtx-2080-ti-gaming-oc.b6097

 

Seeing that the card has a USB-C port onboard, I (never having been accused of having good judgement) popped open the case, and sure enough, confirmed it was a Gigabyte card and it did have a USB-C port! I ran a USB-C cable to one of the 5K screens and it worked perfectly -- still in 4K, but Windows correctly identified it as being on the VirtualLink USB-C port.

 

It's a mystery why CORSAIR didn't run VirtualLink to the front of the case -- there is some context here from a discussion the i160 but it doesn't feel satisfying. But for those of you Googling why VirtualLink is missing from your CORSAIR ONE, I hope this helps.

 

Note #1: CORSAIR may install different cards based on supply, so YMMV. You can check your specific card by using the GPU-Z tool from TechPowerUp.

 

Note #2: I didn't mod the case just for testing the port (I just kinda pinched the USB-C cable in the closed case panel...ahem), but there is a perfect spot on the i164 to drill a hole if you want to run a cable in there (there's already a hole meant for a security lock that I would just expand to fit a USB-C cable). It was super cool to see that the VirtualLink port worked.

 

Back to the problem at hand, though, sadly with one screen working on the USB-C port, the other screen still wouldn't work on any of the DisplayPorts. So in that sense, no progress made.

 

NVIDIA support recommended contacting Gigabyte about "a limitation on the vBIOS", but that's unintelligible to me. Will report back with what I hear, and ideas welcome.

Link to comment
Share on other sites

Hmmm... interesting... from the thread that you linked

 

"Unfortunately, I can't since that is subject to change based on supply.",

 

This probably explains why my 2080 SUPER doesn't have a VirtualLink port when the 2080 SUPER in my old system did. So basically its w/e they have on hand when the system is ordered.

 

It sounds like your issue may be related to the specific card they they picked to put in your machine. vBIOS is basically the same thing as motherboard BIOS, but it lives on the actual graphics card. Manufacturers twek things in their BIOS, like max power limit, based on the particular model and/or binning. People have flashed vBIOS from other cards, most notably flashing a 5700 with the vBIOS of the 5700XT in order to get moer performance.

 

I would be surprised though if the graphics card manufacturer was able to / actually limited the card to only one 4k monitor via the vBIOS

 

I would think that it may be a windows driver issue not installing the second monitor because the first was already connected.

 

You wouldn't happen to have a different 4k monitor to test with other than the LG UltraFine?

Link to comment
Share on other sites

Nice timing, @Azureblood2 -- I just did test with a friend's LG 4K. And it works fine (with either 5K screen). So this configuration works:

 

CORSAIR ONE:

• DisplayPort 1 -> DP-USB-C cable -> LG UltraFine 5K (running in 4K)

• DisplayPort 2 -> DP cable -> LG 4K

 

Both screens are on and functional. I also swapped out the 5K screens just to be sure; both of them still work (with their respective cables) when combined with the 4K screen.

 

(Arrgghh)

 

My best guess is that for some reason (especially because the NVIDIA Control Panel links me to documents about 5K screens -- it seems to "know" what's connected), the NVIDIA drivers, the Gigabyte card, or Windows is saying "I detect two 5K screens, I'm only going to turn one on", even though it can only drive them in 4K.

 

Maddening.

 

I wonder if there's a way to trick Windows or the card into thinking a different 4K screen is plugged in...

Link to comment
Share on other sites

 Share

×
×
  • Create New...