Jump to content
Corsair Community

iCue Update Broke my ST100


Profarb
 Share

Recommended Posts

Yet another iCue software issue...

 

The previous software update seems to have bricked my ST100 headset stand... The newest update to 3.31.81 has fixed nothing, and I still have a $50-$60 paperweight.

 

I have tried to go back to an older version, back to when I know it worked, but still nothing. When I boot up my computer, the ST100 will not even light up, I can manually get the LEDs to turn on by unplugging it and plugging it back in, but at the end of the day, the computer does not recognize it, and iCue doesn't think it exists either. Both of the USB pass-throughs do not work either since the previous 3.30.97 software version that killed it in the first place.

 

I have sent an inquiry into Corsair and have not received any info back. Honestly at this point, I don't really think I will, there seems to be a list a mile long of customers of the Corsair products that have issues, and Corsair does nothing about it....

 

 

Can the forum provide anything for me to try? This point I am wondering if its something permanently wrong with the ST100 with how it doesn't boot up. I searched to try and find just the driver for the ST100, and I was unable to locate that. Granted I do not even know if that would remotely fix anything at this point.

Link to comment
Share on other sites

 Share

×
×
  • Create New...