Jump to content
Corsair Community

3.31.81 Auto Audio Repositioning


--MAILMAN-
 Share

Recommended Posts

So I did some experimenting with it, I don't know exactly what it does, but it does do something noticeable for me at least.

 

I had this issue with iCUE that every time I updated it I would start to get this weird audio bug where audio quality would noticeably change. Taking Smite for example; in the main menu where there's a model that's making noise the quality is normal (for my settings anyways), but when I go to the gods screen, the audio would get louder, less bassy and more trebly. This would happen any time I go to a screen with no actual model; it got annoying really fast. Of course Smite wasn't the only game where it occured. I noticed it during actual gameplay in Spyro as well, which is even more jarring when it happens when you're actually playing. I usually had to uninstall and reinstall iCUE a few times to fix it.

 

But with this option, when it's on I get the issue, but when it's off everything is fine. No reinstalls required.

 

So what my idea is that this is an option that they originally assumed was compatible with all headsets and made it default on with no option to turn it off. I'm assuming my reinstalls would break it sometimes, that's why it would come back after every update as the update would fix it. They then realized not every headset is compatible so they added the option to turn it off. Of course this is only speculation; all I know is that it's an easy fix for an issue I've had for a long time.

Link to comment
Share on other sites

So I did some experimenting with it, I don't know exactly what it does, but it does do something noticeable for me at least.

 

I had this issue with iCUE that every time I updated it I would start to get this weird audio bug where audio quality would noticeably change. Taking Smite for example; in the main menu where there's a model that's making noise the quality is normal (for my settings anyways), but when I go to the gods screen, the audio would get louder, less bassy and more trebly. This would happen any time I go to a screen with no actual model; it got annoying really fast. Of course Smite wasn't the only game where it occured. I noticed it during actual gameplay in Spyro as well, which is even more jarring when it happens when you're actually playing. I usually had to uninstall and reinstall iCUE a few times to fix it.

 

But with this option, when it's on I get the issue, but when it's off everything is fine. No reinstalls required.

 

So what my idea is that this is an option that they originally assumed was compatible with all headsets and made it default on with no option to turn it off. I'm assuming my reinstalls would break it sometimes, that's why it would come back after every update as the update would fix it. They then realized not every headset is compatible so they added the option to turn it off. Of course this is only speculation; all I know is that it's an easy fix for an issue I've had for a long time.

 

I've noticed that aswell everytime I update my audio quality changes and need to enable/disable windows enhancements for headphones aswell as surround in iCUE to make it sound as always. Sometimes I even need to uninstall iCUE and remove the headset drivers in Device Manager and then install iCUE.

 

Quite annoying

Edited by BahamutxD
Link to comment
Share on other sites

Agreed in that an explanation of this setting would be nice since it is new. :[pouts:

 

Well this sounds like the problem I am having in the game IL-2 Sturmovik. Everything was fine until an update quite some time ago. The surround sound is normal when I first get in the air (only happens when inside of the cockpit) with both flights in finger four formation where my wingman is slghtly to my right and behind and the second section/division leader and his wingman to my left and slightly behind. As long as I was swiveling my head around (TrackIr or mouse) the sound was fine. When I looked straight over the nose for more than 8 seconds the sound volume would drop like I was trying to keep from keeping the sound of the TV from waking my wife. Move my virtual head and sound level came back to normal. This is with surround on and surround selected for the audio set up in the game. I found this happened also in the game Silent Hunter 4 Wolves of the Pacific whereby when I was on the bridge and had the four diesel engines running the sound would really get quiet behind me until I move my view around and the sound would come back.

 

I will try turning off this Auto Audio Positioning to see if that indeed is the culprit and report back. I just wish there was a way to turn it on and off with the buttons on the headphones (like with the mic, sidetone, dolby/stereo and the presets) because it would make it easier to troubleshoot without having to use the windows key to pop out to the desktop etc.

Link to comment
Share on other sites

This setting appears to have fixed the sound issue. The sound is not dropping out after turning it off.

 

Auto Audio Positioning: The engine sound was effected. Engine if front of the cockpit no sound lost. Engine behind the cockpit like in a P-400 or P-39 engine sound lost after 8 seconds. Any aircraft behind me in the rear quarter and I would lose the sound of their engines. Just flew and entire flight and never lost the engine sound with surround turn on and AAP turned off.

 

You would have thought the ability to turn this setting on/off would have been available when it first got introduced. This issue was not present with the Cue software and early iCue software. The problem for me first occured in the fall of 2019. I had updated the software through the iCue UI as I had with previous versions and hadn't download any from the Corsair web site (other than when I originally purchased and set up my head set). When I could not fix the problem I put in a request for the previous version of the softtware and Corsair provided me with 3.21.88. this fixed the issue. Subsequent updates didn't cause any problems until now. This new user setting fixed this issue.

 

Thanks for explaining what this setting did. I hope they don't remove this option in future updates.

Edited by -)-MAILMAN-
Link to comment
Share on other sites

this update has re-enabled 8CH audio for me! My EQ is working again. I can toggle between 2ch and 8. AAR option seems to be fine turned on at least with Virt SE using USB. Haven't tried in wireless at all. I can't tell if it sounds better AAR on but it is more sound if that makes sense.

 

I'm guessing AAR "works better" with newer models and was on by default in the last updates as others have suggested. Causing issues for most users. The previous update removed any option of surround from my Virtuoso Se which wasn't terrible as I like them in 2ch anyway.

 

Anyone else with the Virts try with AAR on and off to test? The thread suggests older models need it off and my ears don't know if it sounds better either way.

Edited by Sadcat
Link to comment
Share on other sites

  • 2 weeks later...

I think AAR is Corsairs answer to Atmos/DTS yet still retaining 8 Channel 24bit/48kHz. As Atmos and DTS can only run on 2 Channel 16Bit/48kHz.

 

I still need to do more testing on it but it seems to me having more channels is going to give a much better directional audio.

Link to comment
Share on other sites

I think AAR is Corsairs answer to Atmos/DTS yet still retaining 8 Channel 24bit/48kHz. As Atmos and DTS can only run on 2 Channel 16Bit/48kHz.

 

I still need to do more testing on it but it seems to me having more channels is going to give a much better directional audio.

 

That makes sense for how it sounds.

 

I've found dolby atmos to sound best with the virts. discord sounds normal, games sound incredible. With corsair software i can get great game sound but then discord sounds like it's in a cave.

Link to comment
Share on other sites

 Share

×
×
  • Create New...