Jump to content
Corsair Community

ICue disconnects and connects my corsair products


McZulian
 Share

Recommended Posts

I tried to get support for this problem on the spanish forum and didn't get any answer so i'm, trying it here now. I'm sorry if my english is bad.

I have 4 corsair products, Strafe Red Keyboard, Ironclaw RGB Mouse (wired), Void RGB headphones (wired) and the MM800 Polaris Mousepad.

When i have ICUE on, in a completly random way it disconnects and connects all my 4 corsair products and the process lasts like 5 seconds. It is very annoying when it happens while i'm gaming, that 5 seconds could cost a lot, depending on the game it happens. I bought all this corsair products to be able to manage the RGB with icue, but now i must have it closed and use the default lights of my products so this problem does not happen.

How can i fix it?

It started happening when i installed a newer version of windows 10 (i had the 199somehting and i updated it to the 2004 version with a fresh windows install so i could use the gpu scheduling thing for rtx cards)

My Specs:

CPU:Ryzen 5 3600

Mobo: Gigabyte B450M Aorus

Ram: Adata XPG 2x8gb 3000Mhz

GPU: MSI RTX 2060 Super Ventus OC

 

And my corsair products are these, they are all wired, i don't use wireless

Corsair Strafe Red Keyboard (yes, the old one, no rgb)

Ironclaw RGB Mouse

Void Pro RGB Headphones

MM800 Polaris Mousepad.

 

How can i fix this issue? It happens randomly like 2 or 3 times a day.

Should i use an older version of icue?

Or go back to an older version of windows?

Reinstall windows again?

Please Help

Edited by McZulian
Link to comment
Share on other sites

 Share

×
×
  • Create New...