Jump to content
Corsair Community

H150i Pro Stopped Working?


rcmorgan540
 Share

Recommended Posts

So all of the sudden the LED on my H150i pro is flashing red. From what I have read, this seems to indicate the pump has gone bad. Playing call of Duty on my system is now running 90-99 degrees Celsius. I purchased the cooler in May of 2018 from Amazon, and I assume it is still under warranty. When I get home from work I’m going to start the RMA process. My processor is an intel i7-8700k stock with no overclock. Am I right to assume that removing the H150i pro will lower my cpu temps since the pump is not functioning? I am just wandering if it will be safe to use while I wait on a replacement. My theory is that with the pump not working, it is making the 8700k warmer then it would be without any sort of cooling solution. Can anyone back up my theory? Any advice would be appreciated. Can someone also confirm what I have read in that the warranty on the H150i Pro is 5 years? Thanks in advance for any help!!

 

Casey

Link to comment
Share on other sites

I am just wandering if it will be safe to use while I wait on a replacement. My theory is that with the pump not working, it is making the 8700k warmer then it would be without any sort of cooling solution.

 

No. Absolutely do not attempt to power on your system without some cooling system in place, even a broken one. The CPU cooling is really conductive. The water is more of a transport system for moving the waste heat elsewhere. If you power on with nothing there, the CPU has no way to transfer heat. Instant shutdown would be the best case scenario and there are many worse.

 

If the H150i has really stopped working, it will be fairly evident through the coolant temperature (H150i Temp). Normally is will slowly warm to 4-7C above room temp and any load changes are very slow +-1C ever 30-60 seconds. If you have a broken pump or any other flow restricted state, you will see the H150i temp go up very quickly. 30 to 50C in 30-60 seconds. The fact that you can even game at all means you likely have a working pump, but some type of blockage. That is harder to spot straight off, but you will still see a steady rise in coolant temps while sitting on the desktop and once you do warm it up, the coolant temp won't come back down.

 

Go ahead and start a support ticket with Corsair, but leave the H150i installed. They are likely to ask some questions you need it on for anyway.

Link to comment
Share on other sites

 Share

×
×
  • Create New...