Jump to content
Corsair Community

Corsair HS70 wireless headset, unavailable on ICUE


FluxyTerminator
 Share

Recommended Posts

Recently my HS70 Wireless headset has been ‘wirebound’ Meaning that it turns itself off if not plugged into the computer, however on ICUE when I check the battery charge it says 100% charged, when I unplug the headset it proceeds to work for 5 seconds then powers off saying the device is ‘unavailable’ with a caution sign.

 

Solutions I have tried.

I have unplugged the wireless receiver and tried it again on the same device in a different port which didn’t work.

I have fully uninstalled and reinstalled ICUE, checked the drivers were up to date and still didn’t work.

 

Possible causes for concern.

The issue came up soon after a windows update, this may of changed some settings surrounding the compatibility of the device however I have rechecked if the device is the correct settings and all seems correct however the headset still won’t wirelessly connect.

Link to comment
Share on other sites

 Share

×
×
  • Create New...