Jump to content
Corsair Community

ICUE hangs on Installer/loading application


ElivdGeest
 Share

Recommended Posts

I have a problem for a few weeks now that I can't install/use any ICUE version newer than 3.28.70. The Installer will just show "preparing to install..." for a brief moment and do nothing after that. About 20 minutes later I get a message that the installer is no longer responding, with a option to retry but that does nothing.

 

I tried the following things:

-Restarting (obviously)

-Downloading the installer from the site manualy

-Uninstalled the ICUE version that was already installed

-Disabled Windows Defender

 

Tried older versions, and all versions up and including to 3.28.70 will launch the installer just fine.

 

I also tried to make a new local administrator account in windows 10 (using a microsoft account normaly) and the installer of the latest ICUE did actually work! also ICUE works just fine when i tried to launch it in that local account.

 

When I switched back to my microsoft account however, ICUE no longer opened, and also the installer didn't work anymore nor the uninstaller. Only when I switched back to the local account I could get it all working again. I uninstalled ICUE, removed the local account and installed ICUE version 3.28.70 that still worked and that is what I have done about it.

 

Just to see if my desktop computer was at fault at this point, I tried the to install ICUE on my laptop (Dell XPS 15 9570) and it gives the same exact behavior as on my desktop, ICUE was never installed on that machine before.

 

As of the current version 3.33.246 of ICUE, this issue is not resolved.

 

I will appreciate all the help I can get! :biggrin:

Edited by ElivdGeest
Link to comment
Share on other sites

  • 2 months later...
  • 4 weeks later...
 Share

×
×
  • Create New...