Jump to content
Corsair Community

DarkCore Pro SE Firmware Update Fail


Workingman
 Share

Recommended Posts

Good day,

Just received a new DC RGB Pro SE Mouse.

Got it up and running in iCue and was successful in setting it up and adjusting some settings, lighting, etc.

I saw that the current firmware (V 0.6.23) was a bit behind the available new firmware (v 1.3.9) so I decided to update.

Plugged in the USB cable to the front header of my PC (next to where I installed the dongle) and hit update. iCue asked me to plug it in to the USB cable?!?! But it is already plugged in. Tried unplugging and plugging back in but iCue will not recognize that it is plugged in. Tried aborting the update and received the message that the mouse will be inoperable if I did, with all options used up, I aborted and tried rebooting the system with the same results of not being able to update the mouse firmware, iCue still asking for the mouse to be plugged into USB. One promising thing is that the mouse still operates and it actually saved my lighting settings but iCue shows it as "unavailable" under the Home tab and in the settings tab, it shows a red "power" icon.

I am running the current iCue 3.30.97.

One other note is that when the mouse is plugged in with the USB cable, it resorts to the default (Rainbow) lighting and operates but it does render my Logitech keyboard inoperable, so the cable operates, at least to some degree.

Any options to try??

Also, does this mouse have a dual scroll wheel (notched and smooth scrolling)?? It only seems to have notched scrolling.

 

I am running Win10

Gigabyte GA990fxaUD3 MB

AMD FX-6350

16G Corsair Dom RAM

Radeon R9 380 GPU

Corsair RM1000i PSU

 

I hope that I covered all info needed, let me know if I missed any other info.

Thank you!

Edited by Workingman
Link to comment
Share on other sites

 Share

×
×
  • Create New...