Jump to content
Corsair Community

[Guide] How to use LT100 Lighting Towers wirelessly


Fanman03
 Share

Recommended Posts

I recently got a set of LT100 Lighting Towers. I wanted to use them more like decorative lamps however, which meant they needed to be some distance from my PC. The devices have a few built-in lighting presets, but these presets lack the customization that I would like. I then decided to see if I could make them wireless, and do it cheaply as well. I am aware of existing commercial wireless USB repeaters but didn't want to spend $50+ so I figured out how to do it myself. All in all, this project cost me less than $20.

 

Here is a terrible MS Paint drawing explaining how it works:

d2BaCSz.png

 

Supplies Needed:

  • Raspberry Pi (I used a Zero W because it's cheap and has WiFi, but any WiFi enabled Pi will do)
  • microSD Card (8GB or larger)
  • USB-OTG cable
  • microUSB Cable
  • USB power adapter

 

Instructions:

1. Follow this tutorial to get your Pi up and running in headless mode.

 

2. Install the VirtualHere server onto the Pi by typing the following commands into the SSH terminal you opened in Step 1:

wget https://www.virtualhere.com/sites/default/files/usbserver/vhusbdarm
sudo chmod +x ./vhusbdarm
sudo mv vhusbdarm /usr/sbin

 

3. Make VirtualHere server run on boot so your Pi continues to work after power loss by creating a file at this location /etc/systemd/system/virtualhere.service containing this code:

(you can do this by typing sudo nano /etc/systemd/system/virtualhere.service, pasting the contents below, pressing CTRL-O to save and CTRL-X to exit.)

[unit]
Description=VirtualHere USB Sharing
Requires=networking.service
After=networking.service
[service]
ExecStartPre=/bin/sh -c 'logger VirtualHere settling...;sleep 1s;logger VirtualHere settled'
ExecStart=/usr/sbin/vhusbdarm
Type=idle
[install]
WantedBy=multi-user.target

 

4. Type these into the terminal to start the VirtualHere service

systemctl daemon-reload
systemctl enable virtualhere
systemctl start virtualhere

 

5. Plug the microUSB cable from the power adapter into the power socket on your Pi.

 

6. Connect the LS100 to the Pi 's USB port using the OTG adapter.

 

7. Install the VirtualHere Client for Windows

 

8. In the VirtualHere Client, find your Pi and expand the list. You should see a CORSAIR iCUE Smart Lighting Tower. Right-click on the LT100, and check the Auto-Use Device box.

XJu5mAl.png

 

9. Your LT100 should now show up in iCUE.

 

 

I hope this guide was helpful, and if you have any questions feel free to post a reply to this thread.

This same method should work in theory for any other iCUE-controlled device you wish to make wireless.

Edited by Fanman03
Fixed typo
Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...
So I configured everything as described and initially had success connecting my LT-100 by connecting them to the Pi Zero. However, performance started to lag. I kept seeing drop outs with the LT-100. Windows kept dropping it as a USB device. I talked with the developer. He is not a big fan of the Pi Zero-W wireless card. Hopefully, I can sort out the latency on the wifi network that may be causing the issue. If not, the only other option would be to switch to a more powerful Pi to do the heavy lifting of maintaining the wifi connection.
Link to comment
Share on other sites

Talked with FANMAN03 to see what my issues might have been. While the developer is correct that the PI-W has poor wifi performance, I looked at my network link and the signal strength was sufficient that this shouldn't be the issue. I switched power adapters, using one that I knew had a strong 2.5A power deliver, instead of the generic one from Amazon. I have put back into operation and haven't seen another dropout over the last few hours. Hopefully this resolves the issues I have been seeing.
Link to comment
Share on other sites

  • 2 weeks later...

Works a treat! A couple of things to note;

I went the most basic route with this, without setting a root password.

So for the following part, I had to go with 'sudo'

[b]sudo [/b]systemctl daemon-reload
[b]sudo [/b]systemctl enable virtualhere
[b]sudo [/b]systemctl start virtualhere

 

With VirtualHere, I tried to install as a service at the start. This was a bad idea, they want $49USD for a licence for this... Bit rich for my blood. Uninstalled the service and all was good. However, you are limited to 1 Device without a licence.

 

I ran this on a Raspberry Pi Zero (non-W) with a Wi-Pi (not a typo, it's a pretty old USB adapter from when I had my old Raspberry Pi Model B), with a Zero4U USB HAT.

 

LOVE how simple this was to set up even with my little mess ups. You are a legend for this Fanman03.

Edited by Dingo89
Link to comment
Share on other sites

 Share

×
×
  • Create New...