Jump to content
Corsair Community

H115 RGB Platinum fans have no lighting


Keejteej
 Share

Recommended Posts

Hi

 

I have just receieved a brand new pc, and after installing and configuring it seems my radiator fans do not light up. The lighting is fine over the CPU, just nt fans...I haev downloaded ICUE's most current - and in the it shows my MOBO and the H115i, but on the H115i it does not show fans for lighting options, only the fan speed

 

https://i.imgur.com/heXh5ei.png

 

https://i.imgur.com/u44ws9F.png

 

As far as I can tell, the SATA is connected fine, the USB cable from the cooler goes onto the MOBO and plugs into a USB2 connector.

 

The mobo has Aura, but do I need some sortr of controller? I thought that it was all integrated in teh H115, or am I mistaken?

 

Thanks for any help, full PC description in profile

 

KT

Link to comment
Share on other sites

I have the Corsair Hydro H115i RGB Pro XT CPU Cooler (CW-9060044-WW) - at least that is what I ordered and is what is on my invoice, once I finish downloading a game I will check to see if I can find any codes/serials on the device.

 

Does the cooler you mentione dlight up over the CPU?

 

Thanks, KT

 

EDIT - AHHH, seems you are right, but am sure I ordered the one with RGB fans, will go check...thanks

Edited by Keejteej
Link to comment
Share on other sites

You don’t have a H115i Platinum. You have the H115i XT. It’s the same unit in black, but without RGB fans or an onboard lighting controller and a reduced price as a result.

 

Indeed you are correct, in my enthusiasm I guess I presumed the fans were also RGB, not just the CPU cooler part :( Oh well, not much I can do then - still - my case has 3 RGb fans at the front, and the inside is all RGb, plus an extra 120mm RGB fan at rear lol

 

I'll survive - thanks for the help :)

 

KT

Link to comment
Share on other sites

 Share

×
×
  • Create New...