Jump to content
Corsair Community

My new K95 RGB Platinum is running into some problems.


Kojak92
 Share

Recommended Posts

Hi guys!

 

Today Amazon just delivered my new Corsair Keyboard.

 

When I took it out I plugged the 2x USB cords in the back of my computer. I then downloaded the iCUE Software that allows updates and to change and tweak your keyboard: such as color, etc etc.

 

When I plugged it in it lit up and worked perfectly. Could type, play, etc. Worked fine.

 

When iCUE was done it said there was an update so I began updating it and left it alone to do some chores to let it install. When I got back iCUE said there was an error with updating. Internet worked fine. Everything was plugged in. So I closed out of iCUE and rebooted it and tried again. This time the whole keyboard shut off and the same message occurred, but this time it said the keyboard wasn’t plugged in and asked to replug it in to allow the download to continue.

 

So I closed it again. And restarted my computer. But the keyboard doesn’t work now. I have Windows 10-64 bit and the keyboard doesn’t even work and I can’t enter my password (I have my old keyboard still so I’ll use that in the mean time).

 

My Corsair Scimitar PRO works fine (for now) but in iCUE (before turning my computer off) it doesn’t even show up in the products available.

 

What’s even weirder is that power still goes into the keyboard because the keyboard has a USB port to plug your android or iPhone plug in to charge your phone or whatever.

 

I tried the restart your keyboard method, which is holding down the ESC button while unplugging then replugging the USB's while holding ESC until the colors turn back on. Nothing happens. I even turned off iCUE and tried it again. Nothing. I even uninstalled iCUE and the problem is still going on!

 

I also tried doing this on my Macbook Air, nothing happens.

 

I also went into device management (or manager) and uninstalled my USB drivers and restarted the computer / updated them. Nothing.

 

Now I’m stuck out of my computer. I don’t know what the problem is or how to fix it. I bought the:

 

K95 RGB PLATINUM XT Mechanical Gaming Keyboard — CHERRY® MX SPEED

 

I bought the MMO Corsair Mouse scimitar.

 

And the Corsair CA Wireless RBG wireless Se wireless headphones.

 

I haven’t tried the wireless headphones, and don't know if I have a problem with them. So far, just the keyboard.

 

What’s the problem? How do I fix it? Should I return it? Is it defective?

 

I left the Cult of Razer because I was tired of their overpriced items and having the results be absolutely horrible.

 

Corsair always seemed like a good company. And the keyboard looks amazing and all. Just curious what I can do.

 

TL;DR: K95 Corsair Keyboard stopped working during updating it on iCUE. Restarted computer and iCUE multiple times. Now keyboard won’t work / respond to typing or whatever. Unresponsive. Tried plugging it in every USB port on my computer and it won’t light up or work. There’s a USB on the keyboard to charge your phone which works! My phone charges!!

 

Should I return it, and order another one??

 

Any help or tips would be appreciated.

 

Thanks guys. Hope all is well.

 

-Kojak

Link to comment
Share on other sites

Sounds like the firmware update failed, try to reset it.

https://help.corsair.com/hc/en-us/articles/360025465031-How-to-Reset-your-keyboard#h_8ed018d7-3138-4f4b-8d62-f2ca1f239b46

 

Reset your wired keyboard

Most Corsair keyboards have a reset function for fixing unexpected issues.

 

 

 

If you have a K95 RGB Platinum or any MK2 keyboards:

 

1. Unplug the keyboard.

2. With the keyboard unplugged, hold down the ESC key.

3. While holding down the ESC key, plug the keyboard back into the computer.

4. Keep holding the ESC key until the keyboard begins to flash.

5. Unplug the keyboard again, then plug it back in.

 

That should solve your issue, if iCUE want's to update the firmware again please stay at your computer and prevent it from going into idle/sleep.

As a general rule when it comes to firmware updates, never walk away, keep an eye on that everything runs smooth or if any errors show up.

Edited by Mineria
Link to comment
Share on other sites

Hello. Thank you for the reply.

I already wrote in the post that I already tried this method and it doesn’t seem to work at all. Do you know as a rule or thumb how long I’m suppose to hold the ESC button for it to start working again? 10 seconds? 30? A minute? 5?

 

Thank you. Hope all is well.

Link to comment
Share on other sites

 Share

×
×
  • Create New...