Jump to content
Corsair Community

So long corsair...


OkUrSpecial
 Share

Recommended Posts

Since the beginning of times, when I begin my computer hobbies I've always liked the corsair brand. My first purchase of a corsair product was the "corsair saber mouse" great simple mouse nothing much to say. My second purchase was the "VOID RGB ELITE Wireless" it was the first model of the headset. The product was good, although since day one the up and down mechanism on the mic was a bit scuffed, and slowly after a while it just got even worse. Later my headset's life capacity was so bad I had to always have my "wireless" headset wired at all times to remain charged. So I claimed my warranty and it went well, great customer service and I got a newer model of the headset so I thought sweet! A couple years down the line I purchased the "Corsair k70 RGB" and I loved the keyboard so much I purchased the white keycaps which just made it look much better! I never had a problem with the keyboard since now, but more on that later. So a couple of years later (2019) I built myself a whole new PC, and since I have enjoyed the corsair brand so much I decided to pack my computer with some corsair products like; Corsair case, Corsair power supply, and 3 Corsair RGB fans (LL120). After building my new PC I noticed that one of my RGB fans began flickering but would then go back to its normal state. I got concerned but I was hoping it would just go away. A couple of weeks down the line (still having the same problem with my RGB fans) I noticed that my keyboard's RGB lights began flickering but it was odd since it only seemed to affect the keys, "Tab" "q" "w" "e" "f" "g" "h" "j" k" and "x". So I tried to troubleshoot my keyboard and looking through forums to see if anyone had any solutions, but I had no luck. I was bummed and email customer service after a couple of emails back and forth I was told I couple receive a new keyboard and again I thought sweet! But I was wrong since I was told my warranty had ended since November of 2019. And not even a week after this scenario I noticed that that same flickering fan had just blanked out. The fan was still spinning but the RGB was gone. I did some diagnosing and saw that the 3rd port on my RGB hub had gone bad for some reason. So here I am, I think I could fix it if I try to fool the RGB hub that the 3rd port is connected and then I connect my 3rd fan into the 4th port but I would have to see. I don't wanna make a warranty claim but if I have to I will.

fOluRv2Y.thumb.jpeg.70b180466adbaca50cea5c2033f3f9ae.jpeg

MOXbGvAA.thumb.jpeg.d07db3b7a6bb5a29950017ba8accea13.jpeg

Link to comment
Share on other sites

  • Corsair Employees

I'm having trouble understanding, but it sounds like you potentially have a bad LED or port on the hub. You can test via swapping the port connection with one of the working ones to determine if it's the port that's bad. You should also contact support so they help walk you through further troubleshooting.

 

https://help.corsair.com/hc/en-us/requests/new

Link to comment
Share on other sites

 Share

×
×
  • Create New...