Jump to content
Corsair Community

Faulty Firmware help


Bautista
 Share

Recommended Posts

Hello, a week ago i woke up and my keyboard stopped working, neither the keys nor the RGB work anymore. I'm not an expert by any means but from what i've seen on the forums, my keyboard's firmware seems to be faulty. One time the number/caps/scroll lock indicators kept flashing and sometimes the sidelights turn on. I've been trying to fix by myself these last 2 days to no avail. I tried using Corsair-Utility-Engine-v1.0.657,Corsair-Utility-Engine-v1.11.85, Corsair-Utility-Engine-v1.11.86, Corsair-Utility-Engine-v1.12.75, Corsair-Utility-Engine-v1.16.42, Corsair-Utility-Engine-v1.8.122 as well as the newest one available, doing a clean install of each one, to fix the firmware. All of them get stuck at 3% when trying to update it and then fail and stop recognizing the keyboard until y unplug it and plug it back again . I also reinstalled all of the drivers listed under "Universal Series Bus Controllers", "Mice and other Pointing Devices", "Keyboards" and "Human Interface Devices", tried every usb port on my pc, tried connecting both keyboard cables, unplugging everything, restarting my pc, doing a soft reset holding the esc key while plugging it back in, installing 1.30 FW for STRAFE manually, trying to enter bios mode by holding F1 + WinLock but nothing worked. My pc recognizes the keyboard and works just fine, the keyboard is clean and undamaged and i didn't install/buy any software/hardware recently.

I opened a ticket requesting a firmware but in the meantime maybe someone can help me. Thank you

Edit: In case other people experience the same problem, open a ticket and request a firmware, it fixed mine.

Edited by Bautista
Link to comment
Share on other sites

 Share

×
×
  • Create New...