Jump to content
Corsair Community

Windows update 2004 problem


Recommended Posts

Just a quick heads up to anyone that’s scratching their heads regarding an flickering issue with Icue. I updated to windows build 2004 and it caused my h110i rgb platinum to flicker constantly. Reinstalled icue. Uninstalled my motherboard rgb software and still no joy. Luckily remembered I’d installed the latest windows update (build 2004) and removed it. All working again. Tried different icue versions before update removal and was the same. Just thought this may save someone time.

 

Due to the previous issue with usb disconnects with h110, no amount of googling would come up with anything other then that previous usb disconnect issue

 

Your welcome

Link to comment
Share on other sites

  • 2 months later...

Has anyone heard anything else from Corsair? A part of me was all "well, it'll be fixed with the number of complaints, that are very specific to Windows 2004 rev" but I have not seen anything to address this.

 

Obviously people with issues are on this thread, but has anyone heard of people that have no issues on Windows 2004? I know about 10 people with Corsair products and every single one of them have the issue. I am guessing maybe some users don't care or notice, or use steady lights so they do not experience it, but this is a pretty high percentage of failure rate so you'd think the Corsair people would be aware of it.

Link to comment
Share on other sites

  • 9 months later...

Hi ! I had kind of the same situation just after installing the Windows 10 2004 rev update. My K70 LUX RGB went all red and was not detected anymore by the iCUE app. After a few researches I found a video explaining that if the arrow led on your keyboard is blinking then it means that your keyboard went into BIOS mode. I switched back to the normal mode (F1 + corsair windows lock button) and my keyboard was detected again when reinstalling the iCUE. Many fix tutorials online say that in case of problem we should just reset the keyboard but it doesn't seems to switch the BIOS mode to it's original state.

 

Here are the exact step I did:

 

- Uninstall ICUE and all it's components

- Check the BIOS mode button on my keyboard

- Used the keys combo to switch the BIOS mode

- Reset of the keyboard

- Installed iCUE again

 

I hope it will help :)

Edited by rom1win
Added some details + message cleanup
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...