Jump to content
Corsair Community

Uninstall/update issues...and what I found


c3k
 Share

Recommended Posts

Folks,

 

I kept getting freezes when I tried to update my iCUE software. I would get a failure to uninstall or a fail to install at 13%.

 

I followed the FAQ to delete all the registry entries. https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

 

That failed. Upon reboot, there'd still be some iCUE activity and the Corsair folders would re-appear.

 

I opened the Task Manager and found three running processes tied to Corsair. It was whack-a-mole. As I stopped the processes, they would restart.

 

I finally stumbled on an iCUE process. (Alphabetical, so the Corsair listings got my attention.) Once I killed that process, I was able to to stop the three Corsair processes.

 

Then, the uninstall/registry cleaning (as linked above) worked. A reboot, and a manual install of the manually downloaded 3.29.110 worked. (Previously, it would hang at 13%.)

 

Forgive me for the lack of precisely defining what I did and the error messages.

 

The takeaway: a rogue Corsair and iCUE process is not addressed in the FAQ. There was something left behind by one of the previous updates that was causing the conficts.

 

Since the clean install, I have had no more "Corsair.Service.Display.Adapter" errors.

 

Ken

Link to comment
Share on other sites

 Share

×
×
  • Create New...