Jump to content
Corsair Community

iCUE keeps crashing


AnubisX
 Share

Recommended Posts

Hello people.

 

I have an almost 100% corsair setup (only the memories and source are not branded) and almost every time I try to open the iCUE it crashes.

 

I have an almost clean installation of Windows (I have Geforce Experience, Gigabyte apps for PC and motherboard management, 1Password, VmWare, Chrome, Steam and Battle.net installed) and whenever I open the Corsair app it has a small delay and almost always closes automatically.

I thought it was something with Geforce Experience because the overlay tries to run for iCUE, but even deactivating it and closing the Geforce app the problem continues.

 

The errors always happen in some different DLLs, namely: KERNEL32.DLL, USER32.dll and ntdll.dll.

 

Does anyone have any tips of what may be happening?

 

I uploaded an image from iCUE and what I have installed and txt files with error information

icue.thumb.png.b8c722c7cc7a18109c8e969fbbdfea4a.png

kernel32_error.txt

ntdll_error.txt

user32_error.txt

Link to comment
Share on other sites

First lets start with Windows and make sure you don't have any corrupt system files.

Open a elevated CMD prompt (type CMD in the search box on the task bar, right click it and run as Administrator) and then type: SFC /Scannow

then hit Enter. Let it run and see if it reports any corrupt system files and if it repaired them successfully or not. Most of the tiime it will.

 

If it reports it found corrupt system files and could not repair them you can then use the DISM command tool to repair your windows 10 installation.

 

More information on how to use that here: https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image#dism_repair_image_windows10

 

After Windows is all ok. Then I would suggest you completely remove iCUE and reinstall and see if that fixes the issues you are having. Instructions on how to do that can be found here:

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

 

After removing iCUE then reinstall with the latest version. Hopefully this helps get you back to a working configuration.

 

newfiend~

Link to comment
Share on other sites

First lets start with Windows and make sure you don't have any corrupt system files.

Open a elevated CMD prompt (type CMD in the search box on the task bar, right click it and run as Administrator) and then type: SFC /Scannow

then hit Enter. Let it run and see if it reports any corrupt system files and if it repaired them successfully or not. Most of the tiime it will.

 

If it reports it found corrupt system files and could not repair them you can then use the DISM command tool to repair your windows 10 installation.

 

More information on how to use that here: https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image#dism_repair_image_windows10

 

After Windows is all ok. Then I would suggest you completely remove iCUE and reinstall and see if that fixes the issues you are having. Instructions on how to do that can be found here:

https://help.corsair.com/hc/en-us/articles/360025166712-Perform-a-clean-reinstallation-of-the-Corsair-Utility-Engine-iCUE-

 

After removing iCUE then reinstall with the latest version. Hopefully this helps get you back to a working configuration.

 

newfiend~

 

 

Hi, thanks for your help.

 

Unfortunately it doesn't work.

 

I formatted windows yesterday (as I said, it's a practically clean installation) and after checking, there are no corrupted files.

Before formatting, I already felt the same behavior.

 

Before formatting, I had some Logitech equipment (mouse and keyboard), but now my accessories are all Corsair. I believed that there could be incompatibility between the software of the two brands, but now I'm sure that it ins't.

Due to having vmware installed, I wonder if the problem ins't something when I'm running it.

 

If someone from Corsair could help me with how to get more information about the problem, I think I could find out the cause more easily.

Link to comment
Share on other sites

 Share

×
×
  • Create New...