Jump to content
Corsair Community

Corsair HS70 8-channels driver issue?


Rafael44p
 Share

Recommended Posts

Hello everyone,

 

As the title says i'm having trouble with my Corsair HS70 and i bet it's driver related.

 

The issue started when i needed to reinstall windows 10 because mistakes happen and yea i got a nice virus so the only option was reinstall windows 10 and all my settings/programs/games still got lucky it could be worse.

 

On windows 10 in audio settings for hs70 you normally can't select 2-channels, 16bits.... it normally should be 8-Channels and grayed out so you can't change it, i have 7 options for 2-channels instead of that.

 

Also in games/movies the surround doesn't work even if the option is turned on in iCue for 7.1 surround i though it was a bug at first but no.

 

I've tried the following to solve this but haven't solved it yet:

Older iCue programs which i know worked before.

Removing it from windows reinstall everything with and without restarting windows in between steps.

Device manager remove or windows help also didn't work.

Unplug the hs70 usb or leave it plugged in while doing the same steps before this also didn't work.

Fix for corsair iCue after windows update 1903.

Microsoft tech told me to do an "windows upgrade fix" solves 99% of problems they say.

 

Microsoft doesn't have an solution to this problem i've contacted them and they only know how to do the stuff i did on my own besides that "windows upgrade fix" that doesn't change anything at least not for me

 

This leaves me to believe iCue has a driver problem with windows 10 the latest version (2004) in my case which really sucks since it's only a 1 year old device.

 

I think i didn't miss anything but i can't seem to get it to work i hope anyone has a solution or want's to spend some time trying to solve this with me.

Link to comment
Share on other sites

For anyone still reading i've tried installing an older version of windows and updating it to version 2004 and everything works fine as it did before, the only problem is i can't do this because i can't transfer 2tb of data again it takes way too long to install/program everything again.

So now i don't know if it's a compatibility problem with installing windows 10 (2004) directly or it could be something else that i'm overlooking in the process.

 

Tomorrow i'll try running a virtual machine with windows 10 (2004) with a local account and see if that works., could it be that an non local account is changing settings without even knowing what i have?

Link to comment
Share on other sites

 Share

×
×
  • Create New...