Jump to content
Corsair Community

Anyone has a H100I RGB Platinum?


Recommended Posts

I also have this cooler but it got bricked after firmware update. Anyone of you have his cooler and can send me a specific file?

Just search for a H100_Platinum on your C drive and you should a file like this: H100_Platinum(VersionNumber).hex

If you have it, can you give me it please, i lost mine bur i wanna fix my AIO.

Link to comment
Share on other sites

So ive just resolved this now that ive had the time to look at my own H100i_Platnium, i used this method :

 

(SOLVED) I finally managed to unbrick my H115i Platinum RGB !!!

It bricked during firmware update via iCue. RGB turned off, fans went full throttle, and the pump stopped. The usual recipe. It wasn't easy to fix, but works better than taking it out to send it for warranty/repair.

Imma give you the steps, and i hope as many people see this.

1. Search your C: drive for a "H115_Platinum" .hex file. It's a longer name, but you can find it by searching like this. Copy the file to a handy location, like Desktop for example, and rename it to leave only "H115_Platinum_version number.hex"

2. Restart windows in safe mode (F4 option during recovery startup).

3. Make sure none of the Corsair processes did not start, if so, CTRL+SHIFT+ESC and close them.

4. Go to Services (CTRL+SHIFT+ESC -> Services -> Open Services) and DISABLE the Corsair Services. (3 of them)

5. Go to Corsair installation folder (C:/program files...) and locate the following application (do not open it!) XMCBOOTLOADER.EXE.

6. DRAG AND DROP the .hex file from step 1 over the XMCBOOTLOADER.EXE. The app should now connect to the bootloader, and force push the firmware upgrade.

 

If you get an error during first time, do not panic! For mine, it worked on 3rd try! Reboot safemode, make sure all the processes and services from corsair are ended/disabled.

When it will work, unicorn barf will light up instantly, and the fans will go to quiet mode.

 

ALSO, when you want to upgrade the firmware via iCue (very risky), do it in safe mode!

Some processes interfere with the connection between the AIO and iCue (HWInfo, Steam, Logitech control app)

 

I skipped the safe mode step, just made sure there were no applications running from either icue or corsair when i dropped the .hex file on the boot, worked straight away, hopefully it helps!

Link to comment
Share on other sites

  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...