Jump to content
Corsair Community

Rgb backlight Corsair h115i rgb platinum not working


David Vardanyan
 Share

Recommended Posts

Hello all.

Yesterday when I was assembling the computer, I connected the other end of the micro USB cable to the USB connector and it worked, but after reading the wrong information, reconnected the system pump to the connector, after realizing my mistake I returned the wire to the USB connector, but the cooler started to turn, but the backlight didn’t work. It seems to me that I damaged the micro usb cable. if you know where you can buy a new cable, please write.

Thanks for the answer.

Link to comment
Share on other sites

Any micro to 9 pin internal usb cable will work. You should be able to pick a generic one up off Amazon or a computer store. Hopefully that solves the situation.

 

In iCUE, do you see the cooler listed? If so, the cable is working.

 

Pick and instant lighting color from the drop down menu. That will override any current lighting settings. If it does not, the problem could be at the LED. I would also start a support ticket with Corsair now.

Link to comment
Share on other sites

Any micro to 9 pin internal usb cable will work. You should be able to pick a generic one up off Amazon or a computer store. Hopefully that solves the situation.

 

In iCUE, do you see the cooler listed? If so, the cable is working.

 

Pick and instant lighting color from the drop down menu. That will override any current lighting settings. If it does not, the problem could be at the LED. I would also start a support ticket with Corsair now.

 

OK, thanks for answer. I read reviews to Amazon and could not find a cable that would work with aio cooler. I could not install windows because I'm afraid to break cooler.

Link to comment
Share on other sites

There is a difference between "the unit has no power" (lights off, no fans, no pump vibration) and the pump and fans are moving, but the LED is out. The LED does not affect the other two. If the pump and fans are moving, then you can boot up, install iCUE, and see what's going on. It would be a shame to start ordering cables you don't need or if there is a more serious problem, the unit has to go back anyway.
Link to comment
Share on other sites

There is a difference between "the unit has no power" (lights off, no fans, no pump vibration) and the pump and fans are moving, but the LED is out. The LED does not affect the other two. If the pump and fans are moving, then you can boot up, install iCUE, and see what's going on. It would be a shame to start ordering cables you don't need or if there is a more serious problem, the unit has to go back anyway.

 

Yes, the pump from the cooler is functioning, only the backlight is off. But I can’t return it because I ordered this product from the USA to Russia. I would be very happy to order a new cable from the Corsair website, if possible. Thank you for the answers.

Link to comment
Share on other sites

I think you need to get up and running to assess that. Leave the current usb plugged in to cooler and motherboard. See if iCUE detects it. It will still cool the cpu and adjust fan speeds with coolant temp, with or without the usb cable.
Link to comment
Share on other sites

I think you need to get up and running to assess that. Leave the current usb plugged in to cooler and motherboard. See if iCUE detects it. It will still cool the cpu and adjust fan speeds with coolant temp, with or without the usb cable.

 

Ok, thank you for the answers.

Link to comment
Share on other sites

 Share

×
×
  • Create New...