Jump to content
Corsair Community

Corsair One Wifi Issues


baronmind
 Share

Recommended Posts

Ever since downloading the Epic Games Launcher and downloading four games (~260GB total), my 2018 Corsair One's Wifi connection to my home wifi has not been working. When clicking the Wifi icon in the lower right of Windows 10, it will show the wifi is connected as if nothing is wrong, but if I try to load a website in either Chrome or Edge or try to load UPlay, Steam, or Epic Games Launcher, none can connect to the internet. Then, if I re-click the OS Wifi icon it will show the connection as having no internet.

 

I've connected the Wifi to my mobile hotspot and it seems to work fine so the issue appears to be just with my home Wifi; however, all of my other devices connect to this wireless router and have worked as expected just fine for the past week. I've also tested an ethernet connection from the Corsair One to the router and this works too.

 

The router is a Verizon Wifi 6 router. I've tried resetting it multiple times and also tried forgetting the connection in Windows, but neither has done anything. I've also contacted Verizon to see if they might be blocking that connection somehow since I downloaded so much data through that connection, but their tech support said there is no restriction like this.

 

I tried uninstalling the wifi drivers and reinstalling them, but this had no effect. I installed drivers from the Corsair One website, but the system says the drivers already saved are newer and thus it won't install those older drivers. It appears as though every time I uninstall the wireless adapter and delete the drivers, Windows is pulling a backup from a folder (C:\Windows\System32\DriverStore), but I can't delete these files even though my Windows account is an admin. I've tried installing the newest drivers from Intel for the adapter model Wireless-AC 8265, but that has not fixed the issue either. I've tried going into the BIOS to see what options are there, but since I have a Bluetooth keyboard that has no USB connection option, I can't get the BIOS to launch.

 

Any ideas?

Link to comment
Share on other sites

  • 4 weeks later...

Baronmind, allow me to advise you on a solution that could potentially work wonders for you. Is your i160 next to your router or in a different room? Just wondering. I have mine I’m a different room, and let me tell you, the WiFi antenna’s provided with the Corsair One are complete and utter garbage. Why on Earth they have produced such a fantastic machine but provided us all with WiFi that literally doesn’t work properly I’ll never know.

 

It would be interesting to know what your broadband speed test is showing on the i160 and then similarly on your mobile phone?

 

I was having similar issues to you, an internet that was showing up as connected but not really working. I would have to reset the connection or the computer many times just to get a sluggish connection working. Not all off the time, but much of the time.

Eventually I got so fed up with it I decided to do some research to see if I could find better antennas for a stronger signal.

 

I am providing the links below, and let me tell you right now, the difference between the tiny, flimsy, cheap garbage antennas that Corsair provide with the i160 and these Silverstone WAD17 Dual band WiFi Black High Gain Dipole Antenna‘s is like night and day.

 

Please do make sure to buy the Silverstone WAB1B WiFi Magnetic Antenna Black Base for WiFi/Wireless Antenna for them.

 

I assure you, you will achieve maximum power from your router to your i160 and will never look back.

 

https://www.scan.co.uk/products/silverstone-sst-wad17-high-gain-dual-band-wifi-antenna-sma-plug-rp-dipole-black

 

https://www.scan.co.uk/products/sst-wab1b-silverstone-wifi-antenna-circular-magnetic-base-for-wireless-antenna-150cm-cable-black

 

Thank me once you’ve purchased these and connected them. You will see what I’m talking about.

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...
 Share

×
×
  • Create New...