Jump to content
Corsair Community

Dark Core Pro USB dongle doesn't work


Recommended Posts

So i just got the new Dark Core Pro mouse, when i plug the USB dongle in it doesn't detect it in Windows and the 'initialize' button is grayed out, tried it on two different computers and multiple different USB ports, i bought this mouse as a replacement for my 2nd M65 Elite that had left click issues hoping for an improvement but here we are with yet more frustration.

 

Any ideas what i can do?

Link to comment
Share on other sites

I purchased the Harpoon Wireless, and I was having the same Issue. USB Dongle wasnt detected by my PC. I returned it to Amazon and recieved a second mouse and the second mouse is also showing this behavior. I cant force pair like described above its grayed out and I cant press. Is it possible to get two defective products? I have also submited a service ticket about this issue, and another question on this forum. Really looking for a solution.
Link to comment
Share on other sites

I purchased the Harpoon Wireless, and I was having the same Issue. USB Dongle wasnt detected by my PC. I returned it to Amazon and recieved a second mouse and the second mouse is also showing this behavior. I cant force pair like described above its grayed out and I cant press. Is it possible to get two defective products? I have also submited a service ticket about this issue, and another question on this forum. Really looking for a solution.

 

I just got my Dark Core RGB Pro SE and attempted to set it up, until I noticed that the USB dongle isn't recognized. Attempted multiple ports and still the same issue, greyed out "initiate" button for pairing.

 

Can't even update the mouses firmware as it asks me to plug in the usb dongle before it will update.

Link to comment
Share on other sites

If you haven't done so already, I'd highly recommend reaching out to support like Corsair Notepad mentioned. We would like to try and bring your unit in, and have a replacement sent out to you.

 

https://help.corsair.com/

 

I contacted support, was told that I probably just have a faulty dongle, and it wasn't a known issue. Even though I had pointed out to him that there were other posts on the forum from others always experiencing the same issue. He told me there was nothing he could do and couldn't replace the dongle. To contact where I had bought it from (Corsair listing on Amazon) for a return/exchange.

 

This kind of service turned me off from the product to be honest. I arranged for a return and will look into other options instead of the Dark Core since the person I contact didn't seem to want to help with my issue. Disappointing considering half of my PC is Corsair products.

Link to comment
Share on other sites

I contacted support, was told that I probably just have a faulty dongle, and it wasn't a known issue. Even though I had pointed out to him that there were other posts on the forum from others always experiencing the same issue. He told me there was nothing he could do and couldn't replace the dongle. To contact where I had bought it from (Corsair listing on Amazon) for a return/exchange.

 

This kind of service turned me off from the product to be honest. I arranged for a return and will look into other options instead of the Dark Core since the person I contact didn't seem to want to help with my issue. Disappointing considering half of my PC is Corsair products.

 

If you were my customer while I was at Asus, I'd just ship out a dongle. Really, negative feedback isn't worth the cost savings to a company. After learning that this K63 Wireless has no replaceable battery w/o soldering, I find this is a big issue on QA design and planning. I'll probably wind up getting a battery replacement when it's needed and splicing it in, and capping the connections, so that I can easily replace it in the future. (Did this for fan replacement on my PSU)

 

But yeah, seeing how Corsair plays "hide the firmware" for their mice/keyboards, the abysmal increase in Ticket response time, and I won't even mention their iCUE "plug-in" compatibility with my Asus motherboard, and the issues that created. I'm thinking a mechanical kb with Romer-G keys may be the next option.

 

Oh, and the silly "CORSAIR" lettering on top was just stick-on letters, and they sit above the battery, which warms up. Thus many of the letters have fallen off. The ship logo is still going strong, but now my kb is a "R A R" brand. :P

Link to comment
Share on other sites

I am having the same issue except my dark core pro did work for a little while but with a previous version of CUE and i think their may be some issue with firmware or drivers. I don't think getting a new mouse will solve this unfortunately so I may have to get a return and refund setup. Anyone have any ideas as to pinpoint this problem.

 

EDIT: my mouse worked with the wireless receiver for a bit it works with bluetooth but no dongle support whatsoever.

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...
Just got my Dark Core RGB Pro SE today, and same issue. Tried 3 different ports, including the one on my K95, and none of them detect the dongle. Works fine with the included cable. No Bluetooth on my desktop to try that way, either.
Link to comment
Share on other sites

  • 7 months later...

A little old thread but...

 

I bought Dark Core Gaming Pro SE a few weeks ago. It worked fine until today when I downloaded iCUE 4 and did firmware update. Now iCUE doesn't recognize the dongle nor the mouse so I can't adjust the mouse. The mouse is working when I connect it with USB cable or using Bluetooth. The wireless RF mode doesn't work, obviously. I have reseted the mouse and even installed Windows again but no help. Did the firmware update break my mouse?

Link to comment
Share on other sites

I am also having issues pairing my dark core. I am fairly new to corsair products and Im shocked at the lack of support. When trying to find information on how to pair my mouse, Im given a link to instructions showing their old software. Shocking. I own the dark core mouse, a k95 platinum keyboard and 4 sticks of vengeance RAM. I will never spend another penny on corsair products.

That being said, does anyone know how to solve my bluetooth pairing issue? Ive reset the mouse and followed the suggested solutions suggested by corsair and still cant pair.

Link to comment
Share on other sites

  • 2 weeks later...

Okay I've just made an account to give my fix for this issue. Just got a new Dark Core Pro SE. Dongle worked, updated, no longer paired, and the "initiate" pairing button was grey.

 

Simple fix - Plug in the USB C cable to your PC and mouse, the "initiate pairing" button comes on (keep the dongle plugged in), done in seconds. Fixed.

Link to comment
Share on other sites

I strongly believe the iCUE is bugged, not always the dongle. I mean most of the people have said that the problems have started after the firmware update so I believe the iCUE somehow is corrupting the firmware which is causing the pairing and/or detection issues. At least Windows recognized always the dongle without problems. When I plug the dongle in Windows informs me that the new device is detected and it's ready to use.

 

I have tried every single fixes I found on the Net but none of them worked. I gave up and uninstalled the iCUE and used the BT connection. Just a few minutes ago I thought I'll give it again another try. I installed the iCUE and then I did again the very same procedure as always: I reseted the mouse, then I started up my PC while the dongle was plugged in and the mouse was connected via usb cable. The mouse connection switch was on the center position (Dark Core Pro SE). I opened the iCUE, clicked the Dongle icon, then the Device settings link, then the Update button... Now the update process started immediatelly. At this time the iCUE didn't ask me to connect the dongle as it did earlier so it means the iCUE managed to detect it. After the succesful firmware update I clicked the Connections link and noticed that the Initiate button was finally available. Clicking it finalized the job and now my mouse is working perfectly fine (fingers crossed)

Edited by rampageeeee
Link to comment
Share on other sites

  • 4 months later...

Hello, même problème que vous tous ici présent, après l'achat de ma souris Dark core rgb pro la souris a fonctionnée au tout début en sans fil mais très rapidement a cessé de fonctionner et ne fonctionne qu'en filaire maintenant. Je m'aperçois que c'est le dongle qui n'est pas détecté même après avoir racheté une 2ème souris... même problème, Il ne fait pas de bruit quand je le connecte dans les ports USB (ce ne sont pas les ports car testés avec d'autres appareils) et ne s'affiche même pas dans Icue. J'ai absolument tout essayer si quelqu'un a une solution je suis preneur car a ce prix c'est inadmissible. 

Merci d'avance

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...