Jump to content
Corsair Community

Corsair K70 randomly pressing buttons


aleece01
 Share

Recommended Posts

I’ve had my k70 rapidfire for about two years now and have had no issues. About two hours ago my escape key and all of my f keys (except f12 for whatever reason) are randomly spammed and I can’t do anything about it. I’ve tried moving the switch to the bios mode, moving it into a usb 3.0, everything. ive had no issues with the keyboard until now, and it’s been treated fairly well over the past two years with not a lot of use. No other keys are broken, just escape-f11. I pulled up a website that shows keystrokes and recorded a video on my phone.

Link: [ame]

[/ame] (i tried uploading here but it said failed)

 

I’ve updated firmware, reinstalled iCue and everything. It does this randomly, so right now it’s not rapidly pressing buttons but it could randomly start rapid firing (pun intended) keys.

 

Because if this issue, for whatever reason, my escape-f11 keys won’t work even when the keyboard isn’t spazzing out. I initially thought those keys were just lagging behind but I haven’t pressed any of them since I started my computer up and they’re all being spammed. And because of this, I can’t reset the keyboard because my escape key doesn’t work.

 

Genuinely out of ideas here and about ready to throw a rock through my window if this doesn’t stop

Link to comment
Share on other sites

 Share

×
×
  • Create New...