Jump to content
Corsair Community

H100i Pro RGB XT pump noise


StuartLee2018AE
 Share

Recommended Posts

H100i Pro RGB XT pump noise

 

Orientation = laying on table ( pump facing the ceiling )

Quiet, Balanced and Extreme , no bubling noise

 

Orientation = Upgright, pump facing wall

Quiet = Loudest

Balanced = faint

Extreme = Quiet

 

 

Somethings wrong or just bubble?

Already run for hours already.

Link to comment
Share on other sites

I see.... If i put the pump on Extreme, the noise is gone... which i believe it's not the propeller issues, right? What do you think?

 

it will work it self out eventually i had a h80i v2 that did the same after 6 weeks the noise went away

Link to comment
Share on other sites

it will work it self out eventually i had a h80i v2 that did the same after 6 weeks the noise went away

 

that's taking really long... so now changing between pump profile (speeds) it doesn't make noise anymore?

 

Putting Extreme on the PRO XT pump all the time shouldn't be an issue right?

Link to comment
Share on other sites

that's taking really long... so now changing between pump profile (speeds) it doesn't make noise anymore?

 

Putting Extreme on the PRO XT pump all the time shouldn't be an issue right?

 

should be fine corsair products usally have 5 years warranty anyway

Link to comment
Share on other sites

my pump noise has gone you need to wait a few weeks not 2 days lol

 

Omg... weeks?

 

it's gone now? (yours)... all pump profiles? most notably ' Quiet '?

 

do you open up the case panel, and change pump profile and listen to the noise as the pump profile's changing? Close up the case panel and sit back while changing pump speed too?

 

I removed my h100i and give it a shake , and i think it's quieter a bit now... but i still hear very faint krik/pop , i really don't know how to describe it..

 

How normal is normal pump noise? Is it supposed to make no noise or there's noise? The only moving thingy is the impeller... right?

Edited by StuartLee2018AE
Link to comment
Share on other sites

Omg... weeks?

 

it's gone now? (yours)... all pump profiles? most notably ' Quiet '?

 

do you open up the case panel, and change pump profile and listen to the noise as the pump profile's changing? Close up the case panel and sit back while changing pump speed too?

 

I removed my h100i and give it a shake , and i think it's quieter a bit now... but i still hear very faint krik/pop , i really don't know how to describe it..

 

How normal is normal pump noise? Is it supposed to make no noise or there's noise? The only moving thingy is the impeller... right?

 

[ame=

]
[/ame]

no problem now give it 2 weeks should be fine

Link to comment
Share on other sites

It got much quieter now...

 

I disassembled it from the mobo, give it a more good shake, now it's all better... but still can hear very very faint, click/pop , not constant, and only hear it from very very close, where i put my ear on the rear of the casing to actually hear it, so i guess it's acceptable for now.

Link to comment
Share on other sites

 Share

×
×
  • Create New...