Jump to content
Corsair Community

Strafe RGB on mac no device detected


MMV
 Share

Recommended Posts

When i plug in my keyboard (stafe RGB) on my mac its says on Icue "no device detected" I tried to reset my keyboard but it dont worked. I cheked the firmware and that wasent the problem. I reinstaled it and downloaded the last version but nothing worked. So can someone help me? ( sorry if this is bad English but i am from the Netherlands so sorry )
Link to comment
Share on other sites

I bought a strafe mk.2 recently and had the same problem with my mac. I plugged it into my wifes windows based laptop and it worked fine. I plugged it back into the mac and it continued to work. So if you haven't tried it already, that's something for you to look at.
Link to comment
Share on other sites

  • 3 months later...

It took me a long time to figure this out so I hope this helps someone like me. This might not apply to the original post, but hopefully for someone else.

 

I'm not sure about other devices, but my Strafe firmware was outdated. Go onto Bootcamp or maybe someone else's Windows, connect it and open ICUE. In settings, you can update a keyboard firmware . I know the original post said he checked the firmware version, but I was mistaken with the Software Version. Make sure the Firmware Version is up to date.

 

To be exact, I was at a point where it was not detected in Mac, but worked fine on Windows. Everyone's case is different but I would start from making sure with the Firmware Version (and the latest ICUE software).

 

Hopefully this will save time for someone like me. I reached out to Corsair Support and they were so slow and helpless to be honest.

Edited by hongkmo91
Link to comment
Share on other sites

 Share

×
×
  • Create New...