Jump to content
Corsair Community

SDK Problems


bad99gtp
 Share

Recommended Posts

So I'm running the Steam Wallpaper Engine, I thought I had all this figured out, but now it's back to doing the same type of acting up issues and it's really starting to annoy me.

 

So in order to fully get the functionality out of my Stream Deck and my Corsair K95 RGB Platinum XT side buttons incorporated with my* Stream Deck, I literally have to go into the profiling of the iCUE software... Disable the "SDK" and then re-enable it... but than... that takes out my ability to use the side keys as they're intended with my Stream Deck. My Stream Deck doesn't recognize than once I've checked and unchecked the "SDK" button, that I have the iCUE software installed on my computer and doesn't allow me to use the functionality of my side buttons.

 

So I either have to restart my computer... in which then I lose my Fan custom profiling of lighting, and my Keyboard has no backlighting of any sort.

 

Can anyone help me out here so I can have my Wallpaper engine running, and also get the use of my Stream Deck + my Keyboard's Stream Deck key profiles...?

 

Thanks!

Link to comment
Share on other sites

  • 8 months later...

I wish I could I'm having issue as well where stream deck can't connect even with SDK Enabled. And when I restart my PC iQue go nuts and won't connect to anything when SDK is enabled. My K95 goes red even if I replug it in it seems to get the profile and change but then changes back to red default. only way to resolve is to Disable the SDK and not use stream deck.

 

The SDK seems to be causing the problem here's my suggestion disable SDK in iQue when your not running anything that needs it like stream deck. Disable stream deck to load on startup in task manager.

 

Then after launch when you need it enable it and run stream deck. Stream deck will pick it and not cause issues on start up. Then before you shutdown turn off SDK. I've had numerous problems with the SDK being enabled so I always disable it. Extra steps isn't fun so I hope they can fix it and I mean seriously fix it cause I'm having it crash my PC on restarts. If iQue's SDK bricks my PC I will rip out everything Corsair from my house and swiftly replace it.

 

I just checked on restart with SDK Enable and lost connection to all my devices when it loaded. Disabling SDK fixes all my problems but now Stream Deck is unusable. I have to make sure to close it Enable SDK and then re-open Stream Deck. I mean seriously???? Corsair legit I'm a good dev that can find a problem and give a solid solution to fix it give me access to iQue debugable project and I will find out the problem and fix it so I can have a better experience, also Stream Deck cause it's a little annoying to have to relaunch it after enabling the SDK. IPad app from StreamLabs is what I'm gonna use. This G Key stream deck thing is not worth the risk imo. Sadly I was looking forward to using the Keys after never using them. But hey they look cool right?

Edited by Naomarius
Extra Credit
Link to comment
Share on other sites

  • Corsair Employees
I wish I could I'm having issue as well where stream deck can't connect even with SDK Enabled. And when I restart my PC iQue go nuts and won't connect to anything when SDK is enabled. My K95 goes red even if I replug it in it seems to get the profile and change but then changes back to red default. only way to resolve is to Disable the SDK and not use stream deck.

 

You need to disable or uninstall MSI Mystic Light.

Link to comment
Share on other sites

 Share

×
×
  • Create New...